libpng1.6 — security advisory
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, an out-of-bounds read vulnerability exists in png_image_read_composite when processing palette images with PNG_FLAG_OPTIMIZE_ALPHA enabled. The palette compositing code in png_init_read_transformations incorrectly applies background compositing during premultiplication, violating the invariant component ≤ alpha × 257 required by the simplified PNG API. This issue has been patched in version 1.6.51.
- Products
- libpng1.6
- Affected versions
- 1.6.39-2, 1.6.48-1, 1.6.49-1~exp1, 1.6.50-1, 1.6.50-1~exp1
- Fixed versions
- 1.6.39-2+deb12u1, 1.6.48-1+deb13u1, 1.6.51-1
- CVEs
- CVE-2025-64720
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:24 UTC · Revision 1
Source evidence
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, an out-of-bounds read vulnerability exists in png_image_read_composite when processing palette images with PNG_FLAG_OPTIMIZE_ALPHA enabled. The palette compositing code in png_init_read_transformations incorrectly applies background compositing during premultiplication, violating the invariant component ≤ alpha × 257 required by the simplified PNG API. This issue has been patched in version 1.6.51.
osv:DEBIAN-CVE-2025-64720
libpng1.6
Fixed versions: 1.6.39-2+deb12u1
libpng1.6
Fixed versions: 1.6.48-1+deb13u1
libpng1.6
Fixed versions: 1.6.51-1
Complete source record
{
"id": "11ccea3af65f2b1f685eea2203639d5f1cec9f595fa1c72fd8e3c9eb3d893c5c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-64720",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-64720",
"summary": "LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, an out-of-bounds read vulnerability exists in png_image_read_composite when processing palette images with PNG_FLAG_OPTIMIZE_ALPHA enabled. The palette compositing code in png_init_read_transformations incorrectly applies background compositing during premultiplication, violating the invariant component ≤ alpha × 257 required by the simplified PNG API. This issue has been patched in version 1.6.51.",
"evidence": "osv:DEBIAN-CVE-2025-64720",
"products": [
{
"name": {
"value": "libpng1.6",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.39-2+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.6.39-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libpng1.6",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.48-1+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1.6.48-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "libpng1.6",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.51-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.6.48-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.6.49-1~exp1",
"evidence": "/affected/2/versions"
},
{
"value": "1.6.50-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.6.50-1~exp1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2025-64720",
"aliases": [
"DEBIAN-CVE-2025-64720"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.39-2+deb12u1"
}
]
}
],
"package": {
"name": "libpng1.6",
"purl": "pkg:deb/debian/libpng1.6?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.6.39-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-64720.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.48-1+deb13u1"
}
]
}
],
"package": {
"name": "libpng1.6",
"purl": "pkg:deb/debian/libpng1.6?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.6.48-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-64720.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.51-1"
}
]
}
],
"package": {
"name": "libpng1.6",
"purl": "pkg:deb/debian/libpng1.6?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.6.48-1",
"1.6.49-1~exp1",
"1.6.50-1",
"1.6.50-1~exp1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-64720.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:42.455276850Z",
"provider": "osv",
"upstream": [
"CVE-2025-64720"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-64720"
]
},
"related_cves": [
{
"value": "CVE-2025-64720",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 418474,
"published_at": "2025-11-25T00:15:47.46+00:00"
}