bash — security advisory
GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the values of environment variables, which allows remote attackers to execute arbitrary commands via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271, CVE-2014-7169, and CVE-2014-6277.
- Products
- bash
- Affected versions
- Not specified
- Fixed versions
- 4.3-9.2
- CVEs
- CVE-2014-6278
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:52 UTC · Revision 1
Source evidence
GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the values of environment variables, which allows remote attackers to execute arbitrary commands via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271, CVE-2014-7169, and CVE-2014-6277.
osv:DEBIAN-CVE-2014-6278
bash
Fixed versions: 4.3-9.2
bash
Fixed versions: 4.3-9.2
bash
Fixed versions: 4.3-9.2
Complete source record
{
"id": "99d02a131eeac0ae76a481c7ce47b31fb81e38c50764cdd8e3e8b94b4af2e056",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-6278",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-6278",
"summary": "GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the values of environment variables, which allows remote attackers to execute arbitrary commands via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271, CVE-2014-7169, and CVE-2014-6277.",
"evidence": "osv:DEBIAN-CVE-2014-6278",
"products": [
{
"name": {
"value": "bash",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3-9.2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bash",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3-9.2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bash",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3-9.2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2014-6278",
"aliases": [
"DEBIAN-CVE-2014-6278"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3-9.2"
}
]
}
],
"package": {
"name": "bash",
"purl": "pkg:deb/debian/bash?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-6278.json"
},
"ecosystem_specific": {
"urgency": "high"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3-9.2"
}
]
}
],
"package": {
"name": "bash",
"purl": "pkg:deb/debian/bash?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-6278.json"
},
"ecosystem_specific": {
"urgency": "high"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3-9.2"
}
]
}
],
"package": {
"name": "bash",
"purl": "pkg:deb/debian/bash?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-6278.json"
},
"ecosystem_specific": {
"urgency": "high"
}
}
],
"modified": "2026-10-23T16:01:56.225168520Z",
"provider": "osv",
"upstream": [
"CVE-2014-6278"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-6278"
]
},
"related_cves": [
{
"value": "CVE-2014-6278",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 414788,
"published_at": "2014-09-30T10:55:04.723+00:00"
}