Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress <= 9.0.1 - Authenticated (Contributor+) SQL Injection
The Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'question_id' parameter in all versions up to, and including, 9.0.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. CVE-2024-5606 appears to be a duplicate of this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-3592
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 10:24 UTC · Revision 1
Source evidence
Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress <= 9.0.1 - Authenticated (Contributor+) SQL Injection
core-osv · Original sourcePublished 7 Jun 2024, 05:33 UTC
The Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'question_id' parameter in all versions up to, and including, 9.0.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. CVE-2024-5606 appears to be a duplicate of this issue.
osv:CVE-2024-3592
Complete source record
{
"id": "39af5d9135f3078d685ba461451fb6665d27683d866ce8c8cacc52d7ef2c3d19",
"url": "https://osv.dev/vulnerability/CVE-2024-3592",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress <= 9.0.1 - Authenticated (Contributor+) SQL Injection",
"summary": "The Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'question_id' parameter in all versions up to, and including, 9.0.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. CVE-2024-5606 appears to be a duplicate of this issue.",
"evidence": "osv:CVE-2024-3592",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2024-3592",
"aliases": [
"CVE-2024-3592"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/quizandsurveymaster/quiz_master_next",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "44a25300c5c48922905883afb68a5a9734b447fe"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:expresstech:quiz_and_survey_master:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "9.0.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"9.0.1",
"9.0.0",
"8.2.3",
"8.2.2",
"8.2.1",
"8.2.0",
"8.1.19",
"8.1.18",
"8.1.17",
"8.1.16",
"8.1.14",
"8.1.13",
"8.1.12",
"8.1.11",
"8.1.10",
"8.1.9",
"8.1.8",
"8.1.7",
"8.1.5",
"8.1.3",
"8.1.2",
"8.1.1",
"8.1.0",
"8.0.10",
"8.0.9",
"8.0.8",
"8.0.7",
"8.0.6",
"8.0.5",
"8.0.4",
"8.0.3",
"8.0.2",
"8.0.1",
"8.0",
"7.3.14",
"7.3.13",
"7.3.12",
"7.3.11",
"7.3.10",
"7.3.9",
"6.4.2",
"6.4.1",
"6.4",
"6.3.6",
"6.3.5",
"6.3.3",
"6.3.2",
"6.3.1",
"6.2.1",
"6.2.0",
"6.1.2",
"6.1.1",
"6.1.0",
"6.0.4",
"6.0.3",
"6.0.2",
"6.0.1",
"6.0",
"5.3.2",
"5.3.1",
"5.3.0",
"5.2.4",
"5.2.3",
"5.2.2",
"5.2.1",
"5.2.0",
"5.1.7",
"5.1.6",
"5.1.5",
"5.1.4",
"5.1.3",
"5.1.2",
"5.1.1",
"5.1.0",
"5.0.7",
"5.0.6",
"5.0.5",
"5.0.4",
"5.0.3",
"5.0.2",
"5.0.1",
"5.0.0",
"4.7.10",
"4.7.9",
"4.7.8",
"4.7.7",
"4.7.6",
"4.7.5",
"4.7.4",
"4.7.3",
"4.7.2",
"4.7.1",
"4.7.0",
"4.6.7",
"4.6.6",
"4.6.5",
"4.6.4",
"4.6.3",
"4.6.2",
"4.6.1",
"4.6.0",
"4.5.5",
"4.5.4",
"4.5.3",
"4.5.2",
"4.5.1",
"4.5.0",
"4.4.4",
"4.4.3",
"4.4.2",
"4.4.1",
"4.4.0",
"4.3.1",
"4.3.0",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.1.0",
"4.0.1",
"4.0.0",
"3.9.0",
"3.8.2",
"3.8.1",
"3.7.1",
"3.6.1",
"3.5.2",
"3.5.1",
"3.4.1",
"3.3.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-3592.json"
}
}
],
"modified": "2026-10-28T02:30:27.845191401Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/3097878/quiz-master-next/trunk/php/admin/options-page-questions-tab.php",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/fc085413-db43-43e3-9b60-aeb341eed4e1?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/3xxx/CVE-2024-3592.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-3592"
],
"provider_metadata": {
"cwe_ids": [
"CWE-89"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "9.0.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/3xxx/CVE-2024-3592.json"
}
},
"related_cves": [
{
"value": "CVE-2024-3592",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494488,
"published_at": "2024-06-07T05:33:47.004+00:00"
}