Skip to content
Heist/ feed
Back to feed
MediumFix available

prosody — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-32917

An issue was discovered in Prosody before 0.11.9. The proxy65 component allows open access by default, even if neither of the users has an XMPP account on the local server, allowing unrestricted use of the server's bandwidth.

Products
prosody
Affected versions
Not specified
Fixed versions
0.11.9-1
CVEs
CVE-2021-32917
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:23 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-32917

core-osv · Original source

Published 13 May 2021, 16:15 UTC

An issue was discovered in Prosody before 0.11.9. The proxy65 component allows open access by default, even if neither of the users has an XMPP account on the local server, allowing unrestricted use of the server's bandwidth.

osv:DEBIAN-CVE-2021-32917

prosody

Fixed versions: 0.11.9-1

prosody

Fixed versions: 0.11.9-1

prosody

Fixed versions: 0.11.9-1

Complete source record
{
  "id": "281a521cedf8350b6bb8e80576bd1b455712d424306a814f9e31e4e4b2fe17bb",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-32917",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-32917",
    "summary": "An issue was discovered in Prosody before 0.11.9. The proxy65 component allows open access by default, even if neither of the users has an XMPP account on the local server, allowing unrestricted use of the server's bandwidth.",
    "evidence": "osv:DEBIAN-CVE-2021-32917",
    "products": [
      {
        "name": {
          "value": "prosody",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.11.9-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "prosody",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.11.9-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "prosody",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.11.9-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2021-32917",
      "aliases": [
        "DEBIAN-CVE-2021-32917"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.11.9-1"
                }
              ]
            }
          ],
          "package": {
            "name": "prosody",
            "purl": "pkg:deb/debian/prosody?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-32917.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.11.9-1"
                }
              ]
            }
          ],
          "package": {
            "name": "prosody",
            "purl": "pkg:deb/debian/prosody?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-32917.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.11.9-1"
                }
              ]
            }
          ],
          "package": {
            "name": "prosody",
            "purl": "pkg:deb/debian/prosody?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-32917.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:14.765476397Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-32917"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-32917"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-32917",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 420936,
  "published_at": "2021-05-13T16:15:08.29+00:00"
}