HighFix available
ffmpeg — security advisory
Integer overflow in the get_len function in libavutil/lzo.c in FFmpeg before 0.10.14, 1.1.x before 1.1.12, 1.2.x before 1.2.7, 2.0.x before 2.0.5, 2.1.x before 2.1.5, and 2.2.x before 2.2.4 allows remote attackers to execute arbitrary code via a crafted Literal Run.
- Products
- ffmpeg
- Affected versions
- Not specified
- Fixed versions
- 7:2.4.1-1
- CVEs
- CVE-2014-4610
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:50 UTC · Revision 1
Source evidence
Integer overflow in the get_len function in libavutil/lzo.c in FFmpeg before 0.10.14, 1.1.x before 1.1.12, 1.2.x before 1.2.7, 2.0.x before 2.0.5, 2.1.x before 2.1.5, and 2.2.x before 2.2.4 allows remote attackers to execute arbitrary code via a crafted Literal Run.
osv:DEBIAN-CVE-2014-4610
ffmpeg
Fixed versions: 7:2.4.1-1
ffmpeg
Fixed versions: 7:2.4.1-1
ffmpeg
Fixed versions: 7:2.4.1-1
Complete source record
{
"id": "21e1929a1f0798d39633855ccdd454452b8d51f13e86e9bdcb94bb54586523f6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-4610",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-4610",
"summary": "Integer overflow in the get_len function in libavutil/lzo.c in FFmpeg before 0.10.14, 1.1.x before 1.1.12, 1.2.x before 1.2.7, 2.0.x before 2.0.5, 2.1.x before 2.1.5, and 2.2.x before 2.2.4 allows remote attackers to execute arbitrary code via a crafted Literal Run.",
"evidence": "osv:DEBIAN-CVE-2014-4610",
"products": [
{
"name": {
"value": "ffmpeg",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7:2.4.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ffmpeg",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7:2.4.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ffmpeg",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7:2.4.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2014-4610",
"aliases": [
"DEBIAN-CVE-2014-4610"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7:2.4.1-1"
}
]
}
],
"package": {
"name": "ffmpeg",
"purl": "pkg:deb/debian/ffmpeg?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4610.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7:2.4.1-1"
}
]
}
],
"package": {
"name": "ffmpeg",
"purl": "pkg:deb/debian/ffmpeg?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4610.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7:2.4.1-1"
}
]
}
],
"package": {
"name": "ffmpeg",
"purl": "pkg:deb/debian/ffmpeg?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4610.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T16:00:36.405538064Z",
"provider": "osv",
"upstream": [
"CVE-2014-4610"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-4610"
]
},
"related_cves": [
{
"value": "CVE-2014-4610",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 414673,
"published_at": "2020-01-14T16:15:11.4+00:00"
}