Composer vulnerable to ANSI sequence injection
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-67746
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 18:29 UTC · Revision 1
Source evidence
Composer vulnerable to ANSI sequence injection
core-osv · Original sourcePublished 30 Dec 2025, 16:11 UTC
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
osv:CVE-2025-67746
Complete source record
{
"id": "06fcea7bc7e3424529e8afb40b7f9e18a448b61a71a484ca9b488eedd348eaba",
"url": "https://osv.dev/vulnerability/CVE-2025-67746",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Composer vulnerable to ANSI sequence injection",
"summary": "Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.",
"evidence": "osv:CVE-2025-67746",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2025-67746",
"aliases": [
"BIT-composer-2025-67746",
"CVE-2025-67746",
"GHSA-59pp-r3rg-353g"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/composer/composer",
"type": "GIT",
"events": [
{
"introduced": "378b34c5e33c71d194f33e1b73a62ba22148ff13"
},
{
"fixed": "c6ad1d795efbea3f15805c5e5a86c5a60ba3ed87"
},
{
"introduced": "934ee6eed3c3ffd0aeccef7c1d255adcf0752b24"
},
{
"fixed": "fb3bee27676fd852a8a11ebbb1de19b4dada5aba"
},
{
"fixed": "1d40a95c9d39a6b7f80d404ab30336c586da9917"
},
{
"fixed": "5db1876a76fdef76d3c4f8a27995c434c7a43e71"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:getcomposer:composer:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.2.26"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:getcomposer:composer:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.9.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "1d40a95c9d39a6b7f80d404ab30336c586da9917"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "5db1876a76fdef76d3c4f8a27995c434c7a43e71"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "c6ad1d795efbea3f15805c5e5a86c5a60ba3ed87"
}
],
"source": "REFERENCES_TAG",
"original_tag": "2.2.26"
},
{
"range": [
{
"fixed": "fb3bee27676fd852a8a11ebbb1de19b4dada5aba"
}
],
"source": "REFERENCES_TAG",
"original_tag": "2.9.3"
}
]
}
}
],
"versions": [
"2.9.2",
"2.9.1",
"2.9.0",
"2.9.0-RC1",
"2.8.9",
"2.8.8",
"2.8.7",
"2.8.6",
"2.8.5",
"2.8.4",
"2.8.3",
"2.8.2",
"2.8.1",
"2.8.0",
"2.7.9",
"2.7.8",
"2.7.7",
"2.7.6",
"2.7.5",
"2.7.4",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7.0",
"2.6.5",
"2.6.4",
"2.6.3",
"2.6.2",
"2.6.1",
"2.6.0",
"2.5.2",
"2.5.1",
"2.5.0",
"2.4.1",
"2.4.0",
"2.4.0-RC1",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-67746.json"
}
}
],
"modified": "2026-10-28T02:30:31.806672518Z",
"provider": "osv",
"references": [
"https://github.com/composer/composer/releases/tag/2.2.26",
"https://github.com/composer/composer/releases/tag/2.9.3",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/67xxx/CVE-2025-67746.json",
"https://github.com/composer/composer/security/advisories/GHSA-59pp-r3rg-353g",
"https://nvd.nist.gov/vuln/detail/CVE-2025-67746",
"https://github.com/composer/composer/commit/1d40a95c9d39a6b7f80d404ab30336c586da9917",
"https://github.com/composer/composer/commit/5db1876a76fdef76d3c4f8a27995c434c7a43e71"
],
"provider_metadata": {
"cwe_ids": [
"CWE-74"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/67xxx/CVE-2025-67746.json"
}
},
"related_cves": [
{
"value": "CVE-2025-67746",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 498449,
"published_at": "2025-12-30T16:11:04.776+00:00"
}