bash — security advisory
A heap-based buffer overflow exists in GNU Bash before 4.3 when wide characters, not supported by the current locale set in the LC_CTYPE environment variable, are printed through the echo built-in function. A local attacker, who can provide data to print through the "echo -e" built-in function, may use this flaw to crash a script or execute code with the privileges of the bash process. This occurs because ansicstr() in lib/sh/strtrans.c mishandles u32cconv().
- Products
- bash
- Affected versions
- Not specified
- Fixed versions
- 4.3-1
- CVEs
- CVE-2012-6711
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:02 UTC · Revision 1
Source evidence
A heap-based buffer overflow exists in GNU Bash before 4.3 when wide characters, not supported by the current locale set in the LC_CTYPE environment variable, are printed through the echo built-in function. A local attacker, who can provide data to print through the "echo -e" built-in function, may use this flaw to crash a script or execute code with the privileges of the bash process. This occurs because ansicstr() in lib/sh/strtrans.c mishandles u32cconv().
osv:DEBIAN-CVE-2012-6711
bash
Fixed versions: 4.3-1
bash
Fixed versions: 4.3-1
bash
Fixed versions: 4.3-1
Complete source record
{
"id": "61c0d7314d763ba7df3447e94d098cd7849f71c81954aeeb2a64eed1506f5429",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-6711",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2012-6711",
"summary": "A heap-based buffer overflow exists in GNU Bash before 4.3 when wide characters, not supported by the current locale set in the LC_CTYPE environment variable, are printed through the echo built-in function. A local attacker, who can provide data to print through the \"echo -e\" built-in function, may use this flaw to crash a script or execute code with the privileges of the bash process. This occurs because ansicstr() in lib/sh/strtrans.c mishandles u32cconv().",
"evidence": "osv:DEBIAN-CVE-2012-6711",
"products": [
{
"name": {
"value": "bash",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bash",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bash",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2012-6711",
"aliases": [
"DEBIAN-CVE-2012-6711"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3-1"
}
]
}
],
"package": {
"name": "bash",
"purl": "pkg:deb/debian/bash?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-6711.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3-1"
}
]
}
],
"package": {
"name": "bash",
"purl": "pkg:deb/debian/bash?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-6711.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3-1"
}
]
}
],
"package": {
"name": "bash",
"purl": "pkg:deb/debian/bash?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-6711.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:02:55.019123786Z",
"provider": "osv",
"upstream": [
"CVE-2012-6711"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2012-6711"
]
},
"related_cves": [
{
"value": "CVE-2012-6711",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 419793,
"published_at": "2019-06-18T18:15:09.247+00:00"
}