Medium
Security advisory
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. **Note:** It was not proven that this vulnerability can crash the process.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-26144
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 15:51 UTC · Revision 1
Source evidence
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. **Note:** It was not proven that this vulnerability can crash the process.
osv:CVE-2023-26144
Complete source record
{
"id": "c954f82498db7fe79ab09af92b7008016f8250578f752f74e22aec0aa3f97cae",
"url": "https://osv.dev/vulnerability/CVE-2023-26144",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2023-26144",
"summary": "Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. **Note:** It was not proven that this vulnerability can crash the process.",
"evidence": "osv:CVE-2023-26144",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-26144",
"aliases": [
"CVE-2023-26144",
"GHSA-9pv7-vfvm-6vr7"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/graphql/graphql-js",
"type": "GIT",
"events": [
{
"introduced": "f597c694339b7c488f05496806e404659f6ff955"
},
{
"fixed": "8a95335f545024c09abfa0f07cc326f73a0e466f"
},
{
"fixed": "f94b511386c7e47bd0380dcd56553dc063320226"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:graphql:graphql:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "16.3.0"
},
{
"fixed": "16.8.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "f94b511386c7e47bd0380dcd56553dc063320226"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "8a95335f545024c09abfa0f07cc326f73a0e466f"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v16.8.1"
}
]
}
}
],
"versions": [
"v16.8.0",
"v16.7.1",
"v16.7.0",
"v16.6.0",
"v17.0.0-alpha.2",
"v16.5.0",
"v17.0.0-alpha.1",
"v16.4.0",
"v16.3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-26144.json"
}
}
],
"modified": "2026-10-28T02:30:30.334083782Z",
"provider": "osv",
"references": [
"https://github.com/graphql/graphql-js/releases/tag/v16.8.1",
"https://security.snyk.io/vuln/SNYK-JS-GRAPHQL-5905181",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26144.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-26144",
"https://github.com/graphql/graphql-js/issues/3955",
"https://github.com/graphql/graphql-js/commit/f94b511386c7e47bd0380dcd56553dc063320226",
"https://github.com/graphql/graphql-js/pull/3972"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "snyk",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26144.json"
}
},
"related_cves": [
{
"value": "CVE-2023-26144",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497012,
"published_at": "2023-09-20T05:00:02.129+00:00"
}