Critical
Read beyond bounds in ap_strcmp_match()
Type: advisorySources: OSV
Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-28615
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 08:35 UTC · Revision 1
Source evidence
Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.
osv:CVE-2022-28615
Complete source record
{
"id": "b5e3e08092bfd144e47a8e7f9ebd6858ebcdba2d5d3f011e2d164b8716e329c8",
"url": "https://osv.dev/vulnerability/CVE-2022-28615",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Read beyond bounds in ap_strcmp_match()",
"summary": "Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.",
"evidence": "osv:CVE-2022-28615",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2022-28615",
"aliases": [
"BIT-apache-2022-28615",
"CVE-2022-28615"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/httpd",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "5ed6876d88a45356ea39ece729853fc9c9f37e2d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.4.54"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.4.54-rc3-candidate"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-28615.json"
}
}
],
"modified": "2026-10-28T02:30:33.960364102Z",
"provider": "osv",
"references": [
"https://httpd.apache.org/security/vulnerabilities_24.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28615.json",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7QUGG2QZWHTITMABFLVXA4DNYUOTPWYQ/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPY2BLEVJWFH34AX77ZJPLD2OOBYR6ND/",
"https://nvd.nist.gov/vuln/detail/CVE-2022-28615",
"https://security.gentoo.org/glsa/202208-20",
"https://security.netapp.com/advisory/ntap-20220624-0005/"
],
"provider_metadata": {
"cwe_ids": [
"CWE-190"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "Apache HTTP Server"
},
{
"last_affected": "2.4.53"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28615.json"
}
},
"related_cves": [
{
"value": "CVE-2022-28615",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 501167,
"published_at": "2022-06-08T10:00:51+00:00"
}