sudo — security advisory
Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.
- Products
- sudo
- Affected versions
- Not specified
- Fixed versions
- 1.9.12-r1
- CVEs
- CVE-2022-43995
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:19 UTC · Revision 1
Source evidence
Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.
osv:ALPINE-CVE-2022-43995
sudo
Fixed versions: 1.9.12-r1
sudo
Fixed versions: 1.9.12-r1
Complete source record
{
"id": "8770c3b1342bf6c3193f9a0911a1a9ca6d67f16e773451b90ea468aaa6812882",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2022-43995",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2022-43995",
"summary": "Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.",
"evidence": "osv:ALPINE-CVE-2022-43995",
"products": [
{
"name": {
"value": "sudo",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.12-r1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "sudo",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.12-r1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "ALPINE-CVE-2022-43995",
"aliases": [
"ALPINE-CVE-2022-43995"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.9.12-r1"
}
]
}
],
"package": {
"name": "sudo",
"purl": "pkg:apk/alpine/sudo?arch=source",
"ecosystem": "Alpine:v3.14"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-43995.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.9.12-r1"
}
]
}
],
"package": {
"name": "sudo",
"purl": "pkg:apk/alpine/sudo?arch=source",
"ecosystem": "Alpine:v3.15"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-43995.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-15T07:17:54.272651752Z",
"provider": "osv",
"upstream": [
"CVE-2022-43995"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2022-43995"
]
},
"related_cves": [
{
"value": "CVE-2022-43995",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322042,
"published_at": "2022-11-02T14:15:16.187+00:00"
}