Apache HTTP Server: CGI environment variable override
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-65082
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 01:37 UTC · Revision 1
Source evidence
Apache HTTP Server: CGI environment variable override
core-osv · Original sourcePublished 5 Dec 2025, 10:46 UTC
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.
osv:CVE-2025-65082
Complete source record
{
"id": "88245856b2bb34e8ccacf9e4a3282dad5742eb23f261fac0218039a888e4e312",
"url": "https://osv.dev/vulnerability/CVE-2025-65082",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache HTTP Server: CGI environment variable override",
"summary": "Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.",
"evidence": "osv:CVE-2025-65082",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-65082",
"aliases": [
"BIT-apache-2025-65082",
"CVE-2025-65082"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/httpd",
"type": "GIT",
"events": [
{
"introduced": "da5873e80d6eee7a0838793bf68f1d0254745fbb"
},
{
"fixed": "e4a77ef6051b3fe22eafacbcf54855b178a0bddd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.66"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-65082.json"
}
}
],
"modified": "2026-10-28T02:30:52.516087793Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65082.json",
"https://httpd.apache.org/security/vulnerabilities_24.html",
"https://nvd.nist.gov/vuln/detail/CVE-2025-65082"
],
"provider_metadata": {
"cwe_ids": [
"CWE-150"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.4.0"
},
{
"last_affected": "2.4.65"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65082.json"
}
},
"related_cves": [
{
"value": "CVE-2025-65082",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521411,
"published_at": "2025-12-05T10:46:27.138+00:00"
}