Critical
YesWiki before 4.6.7 Authorization Bypass via Public API Mode
Type: advisorySources: OSV
YesWiki before 4.6.7 contains an authorization bypass vulnerability in ApiService::isAuthorized() that allows unauthenticated attackers to call admin-only API routes when public API mode is enabled. Attackers can send requests to endpoints like api/ci/update_config and api/archives to overwrite configuration and list, download, or delete backup archives.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-104467
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 22:17 UTC · Revision 1
Source evidence
YesWiki before 4.6.7 Authorization Bypass via Public API Mode
core-osv · Original sourcePublished 2 Oct 2026, 11:38 UTC
YesWiki before 4.6.7 contains an authorization bypass vulnerability in ApiService::isAuthorized() that allows unauthenticated attackers to call admin-only API routes when public API mode is enabled. Attackers can send requests to endpoints like api/ci/update_config and api/archives to overwrite configuration and list, download, or delete backup archives.
osv:CVE-2026-104467
Complete source record
{
"id": "7be0b8fab2836af1efc9be3107891eaf7a18f360fc2ea94515b431db71c13c97",
"url": "https://osv.dev/vulnerability/CVE-2026-104467",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "YesWiki before 4.6.7 Authorization Bypass via Public API Mode",
"summary": "YesWiki before 4.6.7 contains an authorization bypass vulnerability in ApiService::isAuthorized() that allows unauthenticated attackers to call admin-only API routes when public API mode is enabled. Attackers can send requests to endpoints like api/ci/update_config and api/archives to overwrite configuration and list, download, or delete backup archives.",
"evidence": "osv:CVE-2026-104467",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-104467",
"aliases": [
"CVE-2026-104467",
"GHSA-v527-6r4j-j2w2"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/yeswiki/yeswiki",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "07120ed8971047f504f7ec78060828f1895f475f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.6.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.6.7"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"v4.6.6",
"v4.6.5",
"v4.6.4",
"v4.6.3",
"v4.6.2",
"v4.6.0",
"v4.5.5",
"v4.5.4",
"v4.5.3",
"v4.5.2",
"v4.5.1",
"v4.4.3",
"v4.4.2",
"v4.4.1",
"v4.4.0",
"v4.3.1",
"v4.3.0",
"v4.2.2",
"v4.2.1",
"v4.2.0",
"v4.1.5",
"v4.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-104467.json"
}
}
],
"modified": "2026-10-28T02:30:24.117802184Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/104xxx/CVE-2026-104467.json",
"https://github.com/YesWiki/yeswiki/security/advisories/GHSA-v527-6r4j-j2w2",
"https://nvd.nist.gov/vuln/detail/CVE-2026-104467",
"https://www.vulncheck.com/advisories/yeswiki-before-4.6.7-authorization-bypass-via-public-api-mode"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/104xxx/CVE-2026-104467.json"
}
},
"related_cves": [
{
"value": "CVE-2026-104467",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490506,
"published_at": "2026-10-02T11:38:33.48+00:00"
}