Skip to content
Heist/ feed
Back to feed
Medium

Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error

Type: advisorySources: OSV

Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-24792
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 15:40 UTC · Revision 1

Source evidence

Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error

core-osv · Original source

Published 29 Jan 2025, 15:27 UTC

Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.

osv:CVE-2025-24792
Complete source record
{
  "id": "44db33f11b99e0194fb20c97c1ccc25bff4235ba047c0280e775f854baf4e7eb",
  "url": "https://osv.dev/vulnerability/CVE-2025-24792",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error",
    "summary": "Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.",
    "evidence": "osv:CVE-2025-24792",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-24792",
      "aliases": [
        "CVE-2025-24792",
        "GHSA-f8q2-7fv5-cg93"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/snowflakedb/pdo_snowflake",
              "type": "GIT",
              "events": [
                {
                  "introduced": "328807eb2aa723e1ebcf62e91f835e57cdd47ee2"
                },
                {
                  "fixed": "53edf0f13fcd97d9bcc863328a02a665f311a861"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0.2.0"
                      },
                      {
                        "fixed": "3.1.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0.2.0"
                      },
                      {
                        "last_affected": "3.0.3"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.0.3",
            "v3.0.2",
            "v3.0.1",
            "v3.0.0",
            "v2.0.3",
            "v2.0.2",
            "v2.0.1",
            "v2.0.0",
            "v1.2.7",
            "v1.2.6",
            "v1.2.5",
            "v1.2.4",
            "v1.2.3",
            "v1.2.2",
            "v1.2.1",
            "v1.2.0",
            "v1.1.1",
            "v1.1.0",
            "v1.0.2",
            "v1.0.1",
            "v1.0.0",
            "v0.2.5",
            "v0.2.4",
            "v0.2.3",
            "v0.2.2",
            "v0.2.1",
            "v0.2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-24792.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:51.394229521Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24792.json",
        "https://github.com/snowflakedb/pdo_snowflake/security/advisories/GHSA-f8q2-7fv5-cg93",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-24792"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-195"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24792.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-24792",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 519783,
  "published_at": "2025-01-29T15:27:06.429+00:00"
}