Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-4428

A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-4428
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:22 UTC · Revision 1

Source evidence

CVE-2021-4428

core-osv · Original source

Published 18 Jul 2023, 17:15 UTC

A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.

osv:CVE-2021-4428
Complete source record
{
  "id": "4e477f18396cbafaf4d2ded185e9776f1ddf38b71e705c9b60ef990c36cca147",
  "url": "https://osv.dev/vulnerability/CVE-2021-4428",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-4428",
    "summary": "A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.",
    "evidence": "osv:CVE-2021-4428",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2021-4428",
      "aliases": [
        "CVE-2021-4428"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/what3words/wordpress-autosuggest-plugin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "dd59cbac5f86057d6a73b87007c08b8bfa0c32ac"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:what3words:autosuggest:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.0.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "dd59cbac5f86057d6a73b87007c08b8bfa0c32ac"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "dd59cbac5f86057d6a73b87007c08b8bfa0c32ac"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v4.0.1"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.0.0",
            "v3.0.10",
            "v3.0.9",
            "v3.0.8",
            "v3.0.7",
            "v1.1.0",
            "v1.0.1",
            "v1.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-4428.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:09.920327830Z",
      "provider": "osv",
      "references": [
        "https://github.com/what3words/wordpress-autosuggest-plugin/releases/tag/v4.0.1",
        "https://vuldb.com/?ctiid.234247",
        "https://vuldb.com/?id.234247",
        "https://github.com/what3words/wordpress-autosuggest-plugin/commit/dd59cbac5f86057d6a73b87007c08b8bfa0c32ac",
        "https://github.com/what3words/wordpress-autosuggest-plugin/pull/20"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-4428",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 384913,
  "published_at": "2023-07-18T17:15:11.14+00:00"
}