Skip to content
Heist/ feed
Back to feed
Medium

OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override

Type: advisorySources: OSV

OpenClaw is an npm-distributed application. In versions >= 2026.4.25 and < 2026.8.1, the workspace environment-variable filter did not block variables ending in `_ENDPOINT`, so an untrusted workspace `.env` file could set AZURE_SPEECH_ENDPOINT. Azure Speech preferred that value over the configured region, so when a synthesis or voice-list request was made, the attacker-selected endpoint received the operator's Azure Speech key in the request header, allowing the key to be reused against the operator's Azure Speech resource. Exploitation requires an operator to start OpenClaw in attacker-controlled workspace content with Azure Speech configured with a key and region and no trusted endpoint override set. The issue is fixed in 2026.8.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-100569
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 22:17 UTC · Revision 1

Source evidence

OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override

core-osv · Original source

Published 26 Sept 2026, 02:18 UTC

OpenClaw is an npm-distributed application. In versions >= 2026.4.25 and < 2026.8.1, the workspace environment-variable filter did not block variables ending in `_ENDPOINT`, so an untrusted workspace `.env` file could set AZURE_SPEECH_ENDPOINT. Azure Speech preferred that value over the configured region, so when a synthesis or voice-list request was made, the attacker-selected endpoint received the operator's Azure Speech key in the request header, allowing the key to be reused against the operator's Azure Speech resource. Exploitation requires an operator to start OpenClaw in attacker-controlled workspace content with Azure Speech configured with a key and region and no trusted endpoint override set. The issue is fixed in 2026.8.1.

osv:CVE-2026-100569
Complete source record
{
  "id": "0c0098cb84369c89bb44a7604309483d76f2cef493fa22d154b25b4dcff50576",
  "url": "https://osv.dev/vulnerability/CVE-2026-100569",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override",
    "summary": "OpenClaw is an npm-distributed application. In versions >= 2026.4.25 and < 2026.8.1, the workspace environment-variable filter did not block variables ending in `_ENDPOINT`, so an untrusted workspace `.env` file could set AZURE_SPEECH_ENDPOINT. Azure Speech preferred that value over the configured region, so when a synthesis or voice-list request was made, the attacker-selected endpoint received the operator's Azure Speech key in the request header, allowing the key to be reused against the operator's Azure Speech resource. Exploitation requires an operator to start OpenClaw in attacker-controlled workspace content with Azure Speech configured with a key and region and no trusted endpoint override set. The issue is fixed in 2026.8.1.",
    "evidence": "osv:CVE-2026-100569",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-100569",
      "aliases": [
        "CVE-2026-100569",
        "GHSA-pfrw-r5vr-89hw"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/openclaw/openclaw",
              "type": "GIT",
              "events": [
                {
                  "introduced": "aa36ee670b76211426a2e89a84e9096453c01ee7"
                },
                {
                  "fixed": "ea806575e6450e4d1efdfc72c19f04be982a1b9b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "2026.4.25"
                      },
                      {
                        "fixed": "2026.8.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandardRange"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2026.8.1"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-100569.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:24.127389092Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/100xxx/CVE-2026-100569.json",
        "https://github.com/openclaw/openclaw/security/advisories/GHSA-pfrw-r5vr-89hw",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-100569",
        "https://www.vulncheck.com/advisories/openclaw-before-2026.8.1-credential-exposure-via-endpoint-override"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-522"
        ],
        "cna_assigner": "VulnCheck",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/100xxx/CVE-2026-100569.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-100569",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490493,
  "published_at": "2026-09-26T02:18:58.839+00:00"
}