Post and Page Builder by BoldGrid <= 1.27.6 - Path Traversal to Authenticated (Contributor+) Arbitrary File Read via template_via_url Function
The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.27.6 via the template_via_url() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-0859
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:54 UTC · Revision 1
Source evidence
Post and Page Builder by BoldGrid <= 1.27.6 - Path Traversal to Authenticated (Contributor+) Arbitrary File Read via template_via_url Function
core-osv · Original sourcePublished 6 Feb 2025, 09:21 UTC
The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.27.6 via the template_via_url() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
osv:CVE-2025-0859
Complete source record
{
"id": "4282735a50d72116074f45b8a0b2c049a676590d14cdd87bf2ab588eae383b2b",
"url": "https://osv.dev/vulnerability/CVE-2025-0859",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Post and Page Builder by BoldGrid <= 1.27.6 - Path Traversal to Authenticated (Contributor+) Arbitrary File Read via template_via_url Function",
"summary": "The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.27.6 via the template_via_url() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.",
"evidence": "osv:CVE-2025-0859",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-0859",
"aliases": [
"CVE-2025-0859"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/boldgrid/post-and-page-builder",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "f48b71fb1cf128e58d2c09967b323f872487e3a4"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"last_affected": "1.27.6"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:boldgrid:post_and_page_builder:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.27.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.27.6",
"1.27.5",
"1.27.4",
"1.27.3",
"1.27.2",
"1.27.1",
"1.27.0",
"1.26.7",
"1.26.6",
"1.26.5",
"1.26.4",
"1.26.3",
"1.26.2",
"1.26.1",
"1.26.0",
"1.25.1",
"1.25.0",
"1.24.2",
"1.24.0",
"1.23.2",
"1.23.1",
"1.23.0",
"1.22.2",
"1.22.1",
"1.22.1-rc1",
"1.21.3",
"1.21.2",
"1.18.0",
"1.17.0",
"1.16.0",
"1.15.2",
"1.15.1",
"1.15.0",
"1.14.2",
"1.14.1",
"1.14.0",
"1.13.6",
"1.13.5",
"1.13.5-rc.1",
"1.13.4",
"1.13.3",
"1.13.3-rc.1",
"1.13.2",
"1.13.1",
"1.13.0",
"1.12.2",
"1.12.0",
"1.12.1",
"1.11.2",
"1.11.1",
"1.11.0",
"1.11.0-rc.1",
"1.10.6",
"1.10.5",
"1.10.4",
"1.10.3",
"1.10.2",
"1.10.1",
"1.10.0",
"1.10.0-rc.1",
"1.9.0",
"1.9.0-rc.3",
"1.9.0-rc.2",
"1.9.0-rc.1",
"1.8.0",
"1.8.0-rc.5",
"1.8.0-rc.4",
"1.8.0-rc.3",
"1.8.0-rc.2",
"1.8.0-rc.1",
"1.8.0-alpha.3",
"1.8.0-alpha.1",
"1.7.1",
"1.7.0",
"1.7.0-rc.5",
"1.7.0-rc.4",
"1.7.0-rc.3",
"1.7.0-rc.2",
"1.7.0-rc.1",
"1.7.0-alpha.2",
"1.7.0-alpha.1",
"1.6.1",
"1.6",
"1.5.2",
"1.5.1",
"1.4.8",
"1.4.7",
"1.4.6",
"1.4.4",
"1.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.3.5",
"1.3.4",
"1.3.3",
"1.3.2",
"1.3.1",
"1.2.13",
"1.2.9",
"1.2.8",
"1.2.7",
"1.2.6",
"uability-testing",
"1.1.3",
"1.1.2",
"1.1.1.2",
"1.1",
"1.1.1.1",
"1.1.1",
"1.0.9",
"1.0.8"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-0859.json"
}
}
],
"modified": "2026-10-28T02:30:36.794183091Z",
"provider": "osv",
"references": [
"https://github.com/BoldGrid/post-and-page-builder/pull/638/commits/10e4d1d96fd2735379049259d15896fa6dd35471",
"https://plugins.trac.wordpress.org/browser/post-and-page-builder/trunk/includes/class-boldgrid-editor-preview.php#L178",
"https://plugins.trac.wordpress.org/changeset?old=3234175&old_path=post-and-page-builder%2Ftags%2F1.27.7%2Fincludes%2Fclass-boldgrid-editor-preview.php&new=3234175&new_path=post-and-page-builder%2Ftags%2F1.27.7%2Fincludes%2Fclass-boldgrid-editor-preview.php",
"https://wordpress.org/plugins/post-and-page-builder/#developers",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/111a1e7f-bc87-4130-a0b2-422d0f98afb6?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/0xxx/CVE-2025-0859.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-0859"
],
"provider_metadata": {
"cwe_ids": [
"CWE-22"
],
"cna_assigner": "Wordfence",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/0xxx/CVE-2025-0859.json"
}
},
"related_cves": [
{
"value": "CVE-2025-0859",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504206,
"published_at": "2025-02-06T09:21:17.984+00:00"
}