Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-10694

alto-saxophone is a module to install and launch Chromedriver for Mac, Linux or Windows. alto-saxophone versions below 2.25.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-10694
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:26 UTC · Revision 1

Source evidence

CVE-2016-10694

core-osv · Original source

Published 4 Jun 2018, 16:29 UTC

alto-saxophone is a module to install and launch Chromedriver for Mac, Linux or Windows. alto-saxophone versions below 2.25.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

osv:CVE-2016-10694
Complete source record
{
  "id": "ac0b3a2749f62d5ace2050e598f8d47adbb7cb9ed92b88418a9078bf7d7a143a",
  "url": "https://osv.dev/vulnerability/CVE-2016-10694",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-10694",
    "summary": "alto-saxophone is a module to install and launch Chromedriver for Mac, Linux or Windows. alto-saxophone versions below 2.25.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.",
    "evidence": "osv:CVE-2016-10694",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2016-10694",
      "aliases": [
        "CVE-2016-10694",
        "GHSA-2p69-gxpm-5469"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/tobli/alto-saxophone",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "87c0a66c045596ad209923a8caf1207479dfad7c"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:alto-saxophone_project:alto-saxophone:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.25.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.25.0",
            "v2.24.0",
            "v2.23.1",
            "v2.23.0",
            "v2.22.0",
            "v2.21.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-10694.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:39.600733716Z",
      "provider": "osv",
      "references": [
        "https://nodesecurity.io/advisories/172"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2016-10694",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 434704,
  "published_at": "2018-06-04T16:29:02.64+00:00"
}