Bruteforce protection can be bypassed with misconfigured proxy
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server prior to versions 26.0.9 and 27.1.4; as well as Nextcloud Enterprise Server prior to versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4; when a (reverse) proxy is configured as trusted proxy the server could be tricked into reading a wrong remote address for an attacker, allowing them executing authentication attempts than intended. Nextcloud Server versions 26.0.9 and 27.1.4 and Nextcloud Enterprise Server versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4 contain a patch for this issue. No known workarounds are available.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-49792
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:03 UTC · Revision 1
Source evidence
Bruteforce protection can be bypassed with misconfigured proxy
core-osv · Original sourcePublished 22 Dec 2023, 16:31 UTC
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server prior to versions 26.0.9 and 27.1.4; as well as Nextcloud Enterprise Server prior to versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4; when a (reverse) proxy is configured as trusted proxy the server could be tricked into reading a wrong remote address for an attacker, allowing them executing authentication attempts than intended. Nextcloud Server versions 26.0.9 and 27.1.4 and Nextcloud Enterprise Server versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4 contain a patch for this issue. No known workarounds are available.
osv:CVE-2023-49792
Complete source record
{
"id": "7fca4794f0dc17960dc3b7d0c6767a9bfce06cfb521da0a01b64afb193a3bf98",
"url": "https://osv.dev/vulnerability/CVE-2023-49792",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Bruteforce protection can be bypassed with misconfigured proxy",
"summary": "Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server prior to versions 26.0.9 and 27.1.4; as well as Nextcloud Enterprise Server prior to versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4; when a (reverse) proxy is configured as trusted proxy the server could be tricked into reading a wrong remote address for an attacker, allowing them executing authentication attempts than intended. Nextcloud Server versions 26.0.9 and 27.1.4 and Nextcloud Enterprise Server versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4 contain a patch for this issue. No known workarounds are available.",
"evidence": "osv:CVE-2023-49792",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-49792",
"aliases": [
"CVE-2023-49792",
"GHSA-5j2p-q736-hw98"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nextcloud/server",
"type": "GIT",
"events": [
{
"introduced": "62cfd3b4c9ff4d8cdbbe6dcc8b63a1085bb94e3d"
},
{
"fixed": "26cc81d62045018b2cbdc7f465228a0456ad9125"
},
{
"introduced": "add4e4365a4040d2e4e6aa79c0d03c3edd78583c"
},
{
"fixed": "2668bd0cd54784b8464b15b23ea7b7336ee1bdc3"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:*",
"range": [
{
"introduced": "26.0.0"
},
{
"fixed": "26.0.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:*",
"range": [
{
"introduced": "26.0.0"
},
{
"fixed": "26.0.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:*",
"range": [
{
"introduced": "27.0.0"
},
{
"fixed": "27.1.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:*",
"range": [
{
"introduced": "27.0.0"
},
{
"fixed": "27.1.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v27.1.4rc1",
"v26.0.9rc1",
"v26.0.8",
"v27.1.3",
"v26.0.8rc2",
"v27.1.3rc2",
"v26.0.8rc1",
"v27.1.3rc1",
"v27.1.2",
"v27.1.2rc1",
"v27.1.1",
"v26.0.7",
"v27.1.0",
"v26.0.6",
"v27.1.0rc4",
"v27.1.0rc3",
"v26.0.6rc1",
"v27.1.0rc2",
"v27.1.0rc1",
"v27.1.0beta3",
"v27.1.0beta2",
"v26.0.5",
"v27.0.2",
"v26.0.5rc1",
"v27.0.2rc1",
"v26.0.4",
"v27.0.1",
"v26.0.4rc2",
"v27.0.1rc2",
"v26.0.4rc1",
"v27.0.1rc1",
"v26.0.3",
"v26.0.3rc2",
"v26.0.3rc1",
"v27.0.0",
"v26.0.2",
"v26.0.2rc1",
"v26.0.1",
"v26.0.1rc1",
"v26.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-49792.json"
}
}
],
"modified": "2026-10-28T02:30:25.083867406Z",
"provider": "osv",
"references": [
"https://hackerone.com/reports/2230915",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/49xxx/CVE-2023-49792.json",
"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5j2p-q736-hw98",
"https://nvd.nist.gov/vuln/detail/CVE-2023-49792",
"https://github.com/nextcloud/server/pull/41526"
],
"provider_metadata": {
"cwe_ids": [
"CWE-307"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "23.0.0"
},
{
"fixed": "23.0.12.13"
},
{
"introduced": "24.0.0"
},
{
"fixed": "24.0.12.9"
},
{
"introduced": "25.0.0"
},
{
"fixed": "25.0.13.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/49xxx/CVE-2023-49792.json"
}
},
"related_cves": [
{
"value": "CVE-2023-49792",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491409,
"published_at": "2023-12-22T16:31:17.833+00:00"
}