HighFix available
vim — security advisory
Buffer Over-read in function find_next_quote in GitHub repository vim/vim prior to 8.2.4925. This vulnerabilities are capable of crashing software, Modify Memory, and possible remote execution
- Products
- vim
- Affected versions
- Not specified
- Fixed versions
- 2:9.0.0135-1
- CVEs
- CVE-2022-1629
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:35 UTC · Revision 1
Source evidence
Buffer Over-read in function find_next_quote in GitHub repository vim/vim prior to 8.2.4925. This vulnerabilities are capable of crashing software, Modify Memory, and possible remote execution
osv:DEBIAN-CVE-2022-1629
vim
Fixed versions: 2:9.0.0135-1
vim
Fixed versions: 2:9.0.0135-1
vim
Fixed versions: 2:9.0.0135-1
Complete source record
{
"id": "addfe83e935d93cd96a9b9fdc8ee630b1c454b4776e19793c534c24c3ad17a2e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-1629",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-1629",
"summary": "Buffer Over-read in function find_next_quote in GitHub repository vim/vim prior to 8.2.4925. This vulnerabilities are capable of crashing software, Modify Memory, and possible remote execution",
"evidence": "osv:DEBIAN-CVE-2022-1629",
"products": [
{
"name": {
"value": "vim",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:9.0.0135-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "vim",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:9.0.0135-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "vim",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:9.0.0135-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-1629",
"aliases": [
"DEBIAN-CVE-2022-1629"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:9.0.0135-1"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/debian/vim?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-1629.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:9.0.0135-1"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/debian/vim?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-1629.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:9.0.0135-1"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/debian/vim?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-1629.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-15T08:00:49.015266110Z",
"provider": "osv",
"upstream": [
"CVE-2022-1629"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-1629"
]
},
"related_cves": [
{
"value": "CVE-2022-1629",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322668,
"published_at": "2022-05-10T14:15:08.53+00:00"
}