Critical
Security advisory
OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-12166
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:46 UTC · Revision 1
Source evidence
OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution.
osv:CVE-2017-12166
Complete source record
{
"id": "995e532317eb165dfe59b9eb7ad260680c34bc5324513203de960ba181365794",
"url": "https://osv.dev/vulnerability/CVE-2017-12166",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-12166",
"summary": "OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution.",
"evidence": "osv:CVE-2017-12166",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2017-12166",
"aliases": [
"CVE-2017-12166"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openvpn/openvpn",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9779cef26e296bb7c94e336c0a1ea1f4da3276d9"
},
{
"introduced": "307abe7b32e951ece58c7964b3fa72536aee6724"
},
{
"fixed": "1f458322cdaffed02184df8c638bde69256a840a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.3.18"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.3.17",
"v2.4.3",
"v2.3.16",
"v2.3.15",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.3.14",
"v2.3.13",
"contains",
"v2.3.12",
"v2.3.11",
"v2.3.10",
"v2.3.9",
"v2.3.8",
"v2.3.7",
"v2.3.6",
"v2.3.5",
"v2.3.4",
"v2.3.3",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.3_rc2",
"v2.3_rc1",
"v2.3_beta1",
"v2.3_alpha3",
"v2.3_alpha2",
"v2.3-alpha1",
"v2.2-RC2",
"v2.2-RC",
"v2.2-beta5",
"v2.2-beta4",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.1_rc22",
"v2.1_rc21",
"v2.1_rc20",
"v2.1_rc19",
"v2.1_rc18",
"v2.1_rc17",
"v2.1_rc16",
"v2.1_rc15",
"v2.1_rc14",
"v2.1_rc13",
"v2.1_rc12",
"v2.1_rc11",
"v2.1_rc10",
"v2.1_rc9",
"v2.1_rc8",
"v2.1_rc7",
"v2.1_rc6",
"v2.1_rc5",
"v2.1_rc4",
"v2.1_rc3",
"v2.1_rc2",
"v2.1_rc1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-12166.json"
}
}
],
"modified": "2026-10-24T10:30:44.318968990Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html",
"https://community.openvpn.net/openvpn/wiki/CVE-2017-12166"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:*"
],
"vendor_product": "openvpn:openvpn",
"extracted_events": [
{
"range": [
{
"fixed": "2.3.18"
},
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.4"
}
],
"source": "CPE_RANGE"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-12166",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 435845,
"published_at": "2017-10-04T01:29:02.09+00:00"
}