Skip to content
Heist/ feed
Back to feed
Medium

WordPress JetElements For Elementor plugin <= 2.9.2.5 - Cross Site Scripting (XSS) vulnerability

Type: advisorySources: Official CVE List

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.5.

Products
JetElements For Elementor
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-114707
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 08:57 UTC · Revision 1

Source evidence

WordPress JetElements For Elementor plugin <= 2.9.2.5 - Cross Site Scripting (XSS) vulnerability

core-cve · Original source

Published 26 Oct 2026, 10:28 UTC

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.5.

cve:CVE-2026-114707

JetElements For Elementor

Fixed versions: Not specified

Complete source record
{
  "id": "de905355a8a32745ee66d20bc3ee01dc6779c40d94a59e0dff3e77fe46f0a80b",
  "url": "https://www.cve.org/CVERecord?id=CVE-2026-114707",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WordPress JetElements For Elementor plugin <= 2.9.2.5 - Cross Site Scripting (XSS) vulnerability",
    "summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.5.",
    "evidence": "cve:CVE-2026-114707",
    "products": [
      {
        "name": {
          "value": "JetElements For Elementor",
          "evidence": "/containers/cna/affected/0/product"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-114707",
      "aliases": [
        "CVE-2026-114707"
      ],
      "metrics": [
        {
          "format": "CVSS",
          "cvssV3_1": {
            "scope": "CHANGED",
            "version": "3.1",
            "baseScore": 6.5,
            "attackVector": "NETWORK",
            "baseSeverity": "MEDIUM",
            "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L",
            "integrityImpact": "LOW",
            "userInteraction": "REQUIRED",
            "attackComplexity": "LOW",
            "availabilityImpact": "LOW",
            "privilegesRequired": "LOW",
            "confidentialityImpact": "LOW"
          },
          "scenarios": [
            {
              "lang": "en",
              "value": "GENERAL"
            }
          ]
        }
      ],
      "affected": [
        {
          "vendor": "Crocoblock",
          "product": "JetElements For Elementor",
          "versions": [
            {
              "status": "affected",
              "changes": [
                {
                  "at": "2.9.2.6",
                  "status": "unaffected"
                }
              ],
              "version": "0",
              "versionType": "custom",
              "lessThanOrEqual": "2.9.2.5"
            }
          ],
          "packageName": "jet-elements",
          "collectionURL": "https://crocoblock.com",
          "defaultStatus": "unaffected"
        }
      ],
      "modified": "2026-10-26T12:54:33.861Z",
      "provider": "cve",
      "references": [
        "https://patchstack.com/database/wordpress/plugin/jet-elements/vulnerability/wordpress-jetelements-for-elementor-plugin-2-9-2-5-cross-site-scripting-xss-vulnerability?_s_id=cve"
      ],
      "provider_metadata": {
        "adp": [
          {
            "title": "CISA ADP Vulnrichment",
            "metrics": [
              {
                "other": {
                  "type": "ssvc",
                  "content": {
                    "id": "CVE-2026-114707",
                    "role": "CISA Coordinator",
                    "options": [
                      {
                        "Exploitation": "none"
                      },
                      {
                        "Automatable": "no"
                      },
                      {
                        "Technical Impact": "partial"
                      }
                    ],
                    "version": "2.0.3",
                    "timestamp": "2026-10-26T12:45:12.295387Z"
                  }
                }
              }
            ],
            "providerMetadata": {
              "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
              "shortName": "CISA-ADP",
              "dateUpdated": "2026-10-26T12:54:33.861Z"
            }
          }
        ],
        "cna": {
          "orgId": "21595511-bba5-4825-b968-b78d1f9984a3",
          "shortName": "Patchstack",
          "dateUpdated": "2026-10-26T10:29:54.984Z"
        }
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-114707",
        "evidence": "/cveMetadata/cveId"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/containers/cna/metrics"
  },
  "source_id": "core-cve",
  "document_id": 307235,
  "published_at": "2026-10-26T10:28:54.378+00:00"
}