flightgear — security advisory
In FlightGear before 2017.2.1, the FGCommand interface allows overwriting any file the user has write access to, but not with arbitrary data: only with the contents of a FlightGear flightplan (XML). A resource such as a malicious third-party aircraft could exploit this to damage files belonging to the user. Both this issue and CVE-2016-9956 are directory traversal vulnerabilities in Autopilot/route_mgr.cxx - this one exists because of an incomplete fix for CVE-2016-9956.
- Products
- flightgear
- Affected versions
- Not specified
- Fixed versions
- 1:2016.4.4+dfsg-3
- CVEs
- CVE-2017-8921
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:04 UTC · Revision 1
Source evidence
In FlightGear before 2017.2.1, the FGCommand interface allows overwriting any file the user has write access to, but not with arbitrary data: only with the contents of a FlightGear flightplan (XML). A resource such as a malicious third-party aircraft could exploit this to damage files belonging to the user. Both this issue and CVE-2016-9956 are directory traversal vulnerabilities in Autopilot/route_mgr.cxx - this one exists because of an incomplete fix for CVE-2016-9956.
osv:DEBIAN-CVE-2017-8921
flightgear
Fixed versions: 1:2016.4.4+dfsg-3
flightgear
Fixed versions: 1:2016.4.4+dfsg-3
Complete source record
{
"id": "9b778086247f922a74b8cdadc58052d154af736e86b8381f7558b4ef6a841de3",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2017-8921",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2017-8921",
"summary": "In FlightGear before 2017.2.1, the FGCommand interface allows overwriting any file the user has write access to, but not with arbitrary data: only with the contents of a FlightGear flightplan (XML). A resource such as a malicious third-party aircraft could exploit this to damage files belonging to the user. Both this issue and CVE-2016-9956 are directory traversal vulnerabilities in Autopilot/route_mgr.cxx - this one exists because of an incomplete fix for CVE-2016-9956.",
"evidence": "osv:DEBIAN-CVE-2017-8921",
"products": [
{
"name": {
"value": "flightgear",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:2016.4.4+dfsg-3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "flightgear",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:2016.4.4+dfsg-3",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2017-8921",
"aliases": [
"DEBIAN-CVE-2017-8921"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:2016.4.4+dfsg-3"
}
]
}
],
"package": {
"name": "flightgear",
"purl": "pkg:deb/debian/flightgear?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-8921.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:2016.4.4+dfsg-3"
}
]
}
],
"package": {
"name": "flightgear",
"purl": "pkg:deb/debian/flightgear?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-8921.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T18:00:05.372932093Z",
"provider": "osv",
"upstream": [
"CVE-2017-8921"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2017-8921"
]
},
"related_cves": [
{
"value": "CVE-2017-8921",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 335503,
"published_at": "2017-05-12T19:29:00.3+00:00"
}