libpgobject-util-dbadmin-perl — security advisory
The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through 1.5.x, insufficiently sanitizes or escapes variable values used as part of shell command execution, resulting in shell code injection via the create(), run_file(), backup(), or restore() function. The vulnerability allows unauthorized users to execute code with the same privileges as the running application.
- Products
- libpgobject-util-dbadmin-perl
- Affected versions
- Not specified
- Fixed versions
- 0.130.1-1
- CVEs
- CVE-2018-9246
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:17 UTC · Revision 1
Source evidence
The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through 1.5.x, insufficiently sanitizes or escapes variable values used as part of shell command execution, resulting in shell code injection via the create(), run_file(), backup(), or restore() function. The vulnerability allows unauthorized users to execute code with the same privileges as the running application.
osv:DEBIAN-CVE-2018-9246
libpgobject-util-dbadmin-perl
Fixed versions: 0.130.1-1
libpgobject-util-dbadmin-perl
Fixed versions: 0.130.1-1
libpgobject-util-dbadmin-perl
Fixed versions: 0.130.1-1
Complete source record
{
"id": "63463d6c85f2c83258ec17ab2a4f092ba995ca970f072d939ee74251ffb356ee",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-9246",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-9246",
"summary": "The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through 1.5.x, insufficiently sanitizes or escapes variable values used as part of shell command execution, resulting in shell code injection via the create(), run_file(), backup(), or restore() function. The vulnerability allows unauthorized users to execute code with the same privileges as the running application.",
"evidence": "osv:DEBIAN-CVE-2018-9246",
"products": [
{
"name": {
"value": "libpgobject-util-dbadmin-perl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.130.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libpgobject-util-dbadmin-perl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.130.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libpgobject-util-dbadmin-perl",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.130.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2018-9246",
"aliases": [
"DEBIAN-CVE-2018-9246"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.130.1-1"
}
]
}
],
"package": {
"name": "libpgobject-util-dbadmin-perl",
"purl": "pkg:deb/debian/libpgobject-util-dbadmin-perl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-9246.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.130.1-1"
}
]
}
],
"package": {
"name": "libpgobject-util-dbadmin-perl",
"purl": "pkg:deb/debian/libpgobject-util-dbadmin-perl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-9246.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.130.1-1"
}
]
}
],
"package": {
"name": "libpgobject-util-dbadmin-perl",
"purl": "pkg:deb/debian/libpgobject-util-dbadmin-perl?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-9246.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:10.225389564Z",
"provider": "osv",
"upstream": [
"CVE-2018-9246"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-9246"
]
},
"related_cves": [
{
"value": "CVE-2018-9246",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420664,
"published_at": "2018-06-08T01:29:02.17+00:00"
}