Skip to content
Heist/ feed
Back to feed
Critical

5ire vulnerable to Remote Code Execution (RCE) via ECharts

Type: advisorySources: OSV

5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe option parsing vulnerability in the ECharts Markdown plugin allows any user able to submit ECharts code blocks to execute arbitrary JavaScript code in the renderer context. This can lead to Remote Code Execution (RCE) in environments where privileged APIs (such as Electron’s electron.mcp) are exposed, resulting in full compromise of the host system. Version 0.15.3 patches the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-22793
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 06:01 UTC · Revision 1

Source evidence

5ire vulnerable to Remote Code Execution (RCE) via ECharts

core-osv · Original source

Published 21 Jan 2026, 21:06 UTC

5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe option parsing vulnerability in the ECharts Markdown plugin allows any user able to submit ECharts code blocks to execute arbitrary JavaScript code in the renderer context. This can lead to Remote Code Execution (RCE) in environments where privileged APIs (such as Electron’s electron.mcp) are exposed, resulting in full compromise of the host system. Version 0.15.3 patches the issue.

osv:CVE-2026-22793
Complete source record
{
  "id": "7d45b32005c4e8489f10b333f0062b2833909a72840ebb21855838bac830fee0",
  "url": "https://osv.dev/vulnerability/CVE-2026-22793",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "5ire vulnerable to Remote Code Execution (RCE) via ECharts",
    "summary": "5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe option parsing vulnerability in the ECharts Markdown plugin allows any user able to submit ECharts code blocks to execute arbitrary JavaScript code in the renderer context. This can lead to Remote Code Execution (RCE) in environments where privileged APIs (such as Electron’s electron.mcp) are exposed, resulting in full compromise of the host system. Version 0.15.3 patches the issue.",
    "evidence": "osv:CVE-2026-22793",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2026-22793",
      "aliases": [
        "CVE-2026-22793",
        "GHSA-wg3x-7c26-97wj"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/nanbingxyz/5ire",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5acf7edc387d1f18a00555bbd1f5d9b9718d2eaa"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.15.3"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "5acf7edc387d1f18a00555bbd1f5d9b9718d2eaa"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v0.15.3"
                  },
                  {
                    "cpe": "cpe:2.3:a:5ire:5ire:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.15.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.15.2",
            "v0.15.1",
            "v0.14.1",
            "v0.14.0",
            "v0.13.2",
            "v0.13.0",
            "v0.13.1",
            "v0.12.1",
            "v0.12.0",
            "v0.11.3",
            "v0.11.2",
            "v0.11.1",
            "v0.11.0",
            "v0.10.1",
            "v0.9.9",
            "v0.9.8",
            "v0.9.7",
            "v0.9.6",
            "v0.9.5",
            "v0.9.4",
            "v0.9.3",
            "v0.9.2",
            "v0.9.1",
            "v0.9.0",
            "v0.8.3",
            "v0.8.1",
            "v0.8.0",
            "v0.7.9"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-22793.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.277232591Z",
      "provider": "osv",
      "references": [
        "https://github.com/nanbingxyz/5ire/releases/tag/v0.15.3",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/22xxx/CVE-2026-22793.json",
        "https://github.com/nanbingxyz/5ire/security/advisories/GHSA-wg3x-7c26-97wj",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-22793"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-94"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/22xxx/CVE-2026-22793.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-22793",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 492906,
  "published_at": "2026-01-21T21:06:58.205+00:00"
}