Medium
Security advisory
WordPress before 5.2.4 is vulnerable to a stored XSS attack to inject JavaScript into STYLE elements.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-17672
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:34 UTC · Revision 1
Source evidence
WordPress before 5.2.4 is vulnerable to a stored XSS attack to inject JavaScript into STYLE elements.
osv:CVE-2019-17672
Complete source record
{
"id": "d272b16723f0958e58a2170402d83a95d2a526ea0e0a8b982a001da67acc4aaf",
"url": "https://osv.dev/vulnerability/CVE-2019-17672",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-17672",
"summary": "WordPress before 5.2.4 is vulnerable to a stored XSS attack to inject JavaScript into STYLE elements.",
"evidence": "osv:CVE-2019-17672",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-17672",
"aliases": [
"CVE-2019-17672"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9b84a21d66d7da3edec388f49234c1c41daed9ad"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17672.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c5f94fc512bdea317e3e433b22a2f11ef959e515"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17672.json"
}
}
],
"modified": "2026-10-24T10:30:41.315861711Z",
"provider": "osv",
"references": [
"https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html",
"https://seclists.org/bugtraq/2020/Jan/8",
"https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/",
"https://wpvulndb.com/vulnerabilities/9910",
"https://www.debian.org/security/2020/dsa-4599",
"https://www.debian.org/security/2020/dsa-4677"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-17672",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 435120,
"published_at": "2019-10-17T13:15:11+00:00"
}