Medium
Security advisory
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before 1.6.2 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-43812
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 12:00 UTC · Revision 1
Source evidence
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before 1.6.2 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.
osv:CVE-2021-43812
Complete source record
{
"id": "6b99318b95b62d4ec050c448ff1b943a2433b987b5a65e5350c0ee746f4461c6",
"url": "https://osv.dev/vulnerability/CVE-2021-43812",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-43812",
"summary": "The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before 1.6.2 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.",
"evidence": "osv:CVE-2021-43812",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-43812",
"aliases": [
"CVE-2021-43812",
"GHSA-2mqv-4j3r-vjvp"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/auth0/nextjs-auth0",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "762da1e8cd42f79f285f62d5f879b1b77ac9e94d"
},
{
"fixed": "0bbd9f8a0c93af51f607f28633b5fb18c5e48ad6"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:auth0:nextjs-auth0:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.6.2"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "0bbd9f8a0c93af51f607f28633b5fb18c5e48ad6"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.6.1",
"v1.6.0",
"v1.5.0",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.0",
"v1.0.0-beta.2",
"v1.0.0-beta.1",
"v1.0.0-beta.0",
"v0.16",
"v0.15.0",
"v0.13.0",
"v0.12.0",
"v0.11.0",
"v0.10.0",
"v0.9.0",
"v0.8.0",
"v0.7.0",
"v0.6.0",
"v0.5.0",
"v0.4.0",
"v0.3.0",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-43812.json"
}
}
],
"modified": "2026-10-20T10:55:04.295962691Z",
"provider": "osv",
"references": [
"https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-2mqv-4j3r-vjvp",
"https://github.com/auth0/nextjs-auth0/commit/0bbd9f8a0c93af51f607f28633b5fb18c5e48ad6"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-43812",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386821,
"published_at": "2021-12-16T19:15:08.353+00:00"
}