JupyterLab before 4.5.9 Stored XSS via Extension Manager
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.
- Products
- jupyterlab
- Affected versions
- Not specified
- Fixed versions
- 4.5.9
- CVEs
- CVE-2026-67338
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 12:06 UTC · Revision 1
Source evidence
JupyterLab before 4.5.9 Stored XSS via Extension Manager
core-osv · Original sourcePublished 14 Oct 2026, 08:45 UTC
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.
osv:BIT-jupyterlab-2026-67338
jupyterlab
Fixed versions: 4.5.9
Complete source record
{
"id": "b4f86f234904b1cabb8bd7edbd9c27aa87bebff141ee8a8db10b9feb045e875f",
"url": "https://osv.dev/vulnerability/BIT-jupyterlab-2026-67338",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "JupyterLab before 4.5.9 Stored XSS via Extension Manager",
"summary": "JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.",
"evidence": "osv:BIT-jupyterlab-2026-67338",
"products": [
{
"name": {
"value": "jupyterlab",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.5.9",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-jupyterlab-2026-67338",
"aliases": [
"BIT-jupyterlab-2026-67338",
"CVE-2026-67338",
"GHSA-vmhf-c436-hxj4"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.5.9"
}
]
}
],
"package": {
"name": "jupyterlab",
"purl": "pkg:bitnami/jupyterlab",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/jupyterlab/BIT-jupyterlab-2026-67338.json"
}
}
],
"modified": "2026-10-14T11:11:02.670615521Z",
"provider": "osv",
"references": [
"https://github.com/jupyterlab/jupyterlab/commit/4e61e07d0a91145b53fbf96ac74b0387f6bc51f6",
"https://github.com/jupyterlab/jupyterlab/commit/d5d961f6e10a6442dddbf94d9a976b3897055a12",
"https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-vmhf-c436-hxj4",
"https://nvd.nist.gov/vuln/detail/CVE-2026-67338",
"https://www.vulncheck.com/advisories/jupyterlab-before-stored-xss-via-extension-manager"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:python:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2026-67338",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 316245,
"published_at": "2026-10-14T08:45:27.772+00:00"
}