mongoose — security advisory
Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can send a crafted percent-encoded request path to a deployment using MG_ENABLE_DIRLIST and persuade a user to visit it. The mg_http_serve_dir() and listdir() path in src/http.c places the decoded request URI into the title and h1 elements without HTML entity encoding. The resulting reflected cross-site scripting executes in the Mongoose origin and can expose session data or perform actions as the victim. This issue is fixed in version 7.22.
- Products
- mongoose
- Affected versions
- 7.21+ds-1, 7.21+ds-2, 7.22+ds-1, 7.23+ds-1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-73259
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 03:15 UTC · Revision 1
Source evidence
Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can send a crafted percent-encoded request path to a deployment using MG_ENABLE_DIRLIST and persuade a user to visit it. The mg_http_serve_dir() and listdir() path in src/http.c places the decoded request URI into the title and h1 elements without HTML entity encoding. The resulting reflected cross-site scripting executes in the Mongoose origin and can expose session data or perform actions as the victim. This issue is fixed in version 7.22.
osv:UBUNTU-CVE-2026-73259
mongoose
Fixed versions: Not specified
Complete source record
{
"id": "025e64845493fc60c894db4bbbf4a2b8f89e5d6b32abf1958dee9581f7f36f1e",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-73259",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-73259",
"summary": "Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can send a crafted percent-encoded request path to a deployment using MG_ENABLE_DIRLIST and persuade a user to visit it. The mg_http_serve_dir() and listdir() path in src/http.c places the decoded request URI into the title and h1 elements without HTML entity encoding. The resulting reflected cross-site scripting executes in the Mongoose origin and can expose session data or perform actions as the victim. This issue is fixed in version 7.22.",
"evidence": "osv:UBUNTU-CVE-2026-73259",
"products": [
{
"name": {
"value": "mongoose",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "7.21+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.21+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "7.22+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.23+ds-1",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2026-73259",
"aliases": [
"UBUNTU-CVE-2026-73259"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "mongoose",
"purl": "pkg:deb/ubuntu/mongoose?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"7.21+ds-1",
"7.21+ds-2",
"7.22+ds-1",
"7.23+ds-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-73259.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "mongoose-webserver-source",
"binary_version": "7.23+ds-1"
}
]
}
}
],
"modified": "2026-10-17T13:01:02.080762234Z",
"provider": "osv",
"upstream": [
"CVE-2026-73259"
],
"references": [
"https://ubuntu.com/security/CVE-2026-73259",
"https://www.cve.org/CVERecord?id=CVE-2026-73259"
]
},
"related_cves": [
{
"value": "CVE-2026-73259",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 360895,
"published_at": "2026-08-20T18:16:00+00:00"
}