HighFix available
lemonldap-ng — security advisory
In the portal in LemonLDAP::NG before 2.21.0, cross-site scripting (XSS) allows remote attackers to inject arbitrary web script or HTML (into the login page) via the tab parameter, for Choice authentication.
- Products
- lemonldap-ng
- Affected versions
- 2.16.1+ds-2, 2.16.1+ds-deb12u1, 2.16.1+ds-deb12u2, 2.16.1+ds-deb12u3, 2.16.1+ds-deb12u4, 2.16.1+ds-deb12u5
- Fixed versions
- 2.16.1+ds-deb12u6, 2.21.0+ds-1
- CVEs
- CVE-2025-31510
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 05:16 UTC · Revision 1
Source evidence
In the portal in LemonLDAP::NG before 2.21.0, cross-site scripting (XSS) allows remote attackers to inject arbitrary web script or HTML (into the login page) via the tab parameter, for Choice authentication.
osv:DEBIAN-CVE-2025-31510
lemonldap-ng
Fixed versions: 2.16.1+ds-deb12u6
lemonldap-ng
Fixed versions: 2.21.0+ds-1
lemonldap-ng
Fixed versions: 2.21.0+ds-1
Complete source record
{
"id": "7ff545b88861d287292485a9193cb541c93b9758aead4c2f29d4165cf9b24991",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-31510",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-31510",
"summary": "In the portal in LemonLDAP::NG before 2.21.0, cross-site scripting (XSS) allows remote attackers to inject arbitrary web script or HTML (into the login page) via the tab parameter, for Choice authentication.",
"evidence": "osv:DEBIAN-CVE-2025-31510",
"products": [
{
"name": {
"value": "lemonldap-ng",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.16.1+ds-deb12u6",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.16.1+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u4",
"evidence": "/affected/0/versions"
},
{
"value": "2.16.1+ds-deb12u5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "lemonldap-ng",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.21.0+ds-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lemonldap-ng",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.21.0+ds-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2025-31510",
"aliases": [
"DEBIAN-CVE-2025-31510"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.16.1+ds-deb12u6"
}
]
}
],
"package": {
"name": "lemonldap-ng",
"purl": "pkg:deb/debian/lemonldap-ng?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.16.1+ds-2",
"2.16.1+ds-deb12u1",
"2.16.1+ds-deb12u2",
"2.16.1+ds-deb12u3",
"2.16.1+ds-deb12u4",
"2.16.1+ds-deb12u5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-31510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.21.0+ds-1"
}
]
}
],
"package": {
"name": "lemonldap-ng",
"purl": "pkg:deb/debian/lemonldap-ng?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-31510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.21.0+ds-1"
}
]
}
],
"package": {
"name": "lemonldap-ng",
"purl": "pkg:deb/debian/lemonldap-ng?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-31510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-18T04:00:06.136689827Z",
"provider": "osv",
"upstream": [
"CVE-2025-31510"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-31510"
]
},
"related_cves": [
{
"value": "CVE-2025-31510",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 366673,
"published_at": "2026-01-16T18:16:07.363+00:00"
}