Skip to content
Heist/ feed
Back to feed
MediumFix available

libgd2 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-5711

gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1, has an integer signedness error that leads to an infinite loop via a crafted GIF file, as demonstrated by a call to the imagecreatefromgif or imagecreatefromstring PHP function. This is related to GetCode_ and gdImageCreateFromGifCtx.

Products
libgd2
Affected versions
Not specified
Fixed versions
2.2.5-4.1
CVEs
CVE-2018-5711
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 01:34 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-5711

core-osv · Original source

Published 16 Jan 2018, 09:29 UTC

gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1, has an integer signedness error that leads to an infinite loop via a crafted GIF file, as demonstrated by a call to the imagecreatefromgif or imagecreatefromstring PHP function. This is related to GetCode_ and gdImageCreateFromGifCtx.

osv:DEBIAN-CVE-2018-5711

libgd2

Fixed versions: 2.2.5-4.1

libgd2

Fixed versions: 2.2.5-4.1

libgd2

Fixed versions: 2.2.5-4.1

Complete source record
{
  "id": "e8dddf7348ebd137cd609892c21818186bd76eec08be6341992439cb26e4455d",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-5711",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-5711",
    "summary": "gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1, has an integer signedness error that leads to an infinite loop via a crafted GIF file, as demonstrated by a call to the imagecreatefromgif or imagecreatefromstring PHP function. This is related to GetCode_ and gdImageCreateFromGifCtx.",
    "evidence": "osv:DEBIAN-CVE-2018-5711",
    "products": [
      {
        "name": {
          "value": "libgd2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.5-4.1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libgd2",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.5-4.1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libgd2",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.5-4.1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2018-5711",
      "aliases": [
        "DEBIAN-CVE-2018-5711"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.5-4.1"
                }
              ]
            }
          ],
          "package": {
            "name": "libgd2",
            "purl": "pkg:deb/debian/libgd2?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-5711.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.5-4.1"
                }
              ]
            }
          ],
          "package": {
            "name": "libgd2",
            "purl": "pkg:deb/debian/libgd2?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-5711.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.5-4.1"
                }
              ]
            }
          ],
          "package": {
            "name": "libgd2",
            "purl": "pkg:deb/debian/libgd2?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-5711.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:04:48.194532226Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-5711"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-5711"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-5711",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 423847,
  "published_at": "2018-01-16T09:29:00.577+00:00"
}