HighFix available
node — security advisory
Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.
- Products
- node
- Affected versions
- Not specified
- Fixed versions
- 12.22.2, 14.17.2, 16.4.1
- CVEs
- CVE-2021-22921
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:54 UTC · Revision 1
Source evidence
Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.
osv:BIT-node-2021-22921
node
Fixed versions: 12.22.2, 14.17.2, 16.4.1
Complete source record
{
"id": "e04ba6d734c5e753dc2be7624508d29ef4c072fada51392aacf739f0005d7479",
"url": "https://osv.dev/vulnerability/BIT-node-2021-22921",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "BIT-node-2021-22921",
"summary": "Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.",
"evidence": "osv:BIT-node-2021-22921",
"products": [
{
"name": {
"value": "node",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "12.22.2",
"evidence": "/affected/0/ranges"
},
{
"value": "14.17.2",
"evidence": "/affected/0/ranges"
},
{
"value": "16.4.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "BIT-node-2021-22921",
"aliases": [
"BIT-node-2021-22921",
"BIT-node-min-2021-22921",
"CVE-2021-22921"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "12.0.0"
},
{
"fixed": "12.22.2"
},
{
"introduced": "14.0.0"
},
{
"fixed": "14.17.2"
},
{
"introduced": "16.0.0"
},
{
"fixed": "16.4.1"
}
]
}
],
"package": {
"name": "node",
"purl": "pkg:bitnami/node",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/node/BIT-node-2021-22921.json"
}
}
],
"modified": "2026-10-16T09:45:31.316718431Z",
"provider": "osv",
"references": [
"https://hackerone.com/reports/1211160",
"https://nodejs.org/en/blog/vulnerability/july-2021-security-releases/",
"https://security.netapp.com/advisory/ntap-20210805-0003/",
"https://nvd.nist.gov/vuln/detail/CVE-2021-22921"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*"
],
"severity": "High"
}
},
"related_cves": [
{
"value": "CVE-2021-22921",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 338486,
"published_at": "2024-03-06T11:06:44.883+00:00"
}