Medium
Security advisory
A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-40369
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:43 UTC · Revision 1
Source evidence
A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.
osv:CVE-2021-40369
Complete source record
{
"id": "6929966881f7e49257f2f62e99f04075e4ce7324ed53636a85ff87ff3619ca50",
"url": "https://osv.dev/vulnerability/CVE-2021-40369",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-40369",
"summary": "A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.",
"evidence": "osv:CVE-2021-40369",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-40369",
"aliases": [
"CVE-2021-40369",
"GHSA-cfqj-9g2g-w7q6"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/jspwiki",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "b9c3d919beee3a73ffd87cde5021327d3a6544a5"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.11.0-RC1",
"2.11.0.M8-RC1",
"2.11.0.M8",
"2.11.0.M7-RC1",
"2.11.0.M7",
"2.11.0.M6-RC1",
"2.11.0.M6",
"2.11.0.M5-RC3",
"2.11.0.M5",
"2.11.0.M5-RC2",
"2.11.0.M5-RC1",
"2.11.0.M4-RC2",
"2.11.0.M4",
"2.11.0.M4-RC1",
"2.11.0.M3-RC2",
"2.11.0.M3",
"2.11.0.M3-RC1",
"2.11.0.M2-RC1",
"2.11.0.M2",
"2.11.0.M1.RC3",
"2.11.0.M1",
"2.11.0.M1-RC2",
"2.11.0.M1-RC1",
"2.10.5-RC2",
"2.10.5",
"2.10.5-RC1",
"2.10.4-RC3",
"2.10.4",
"2.10.4-RC2",
"2.10.4-RC1",
"2.10.3-RC2",
"2.10.3",
"2.10.3-RC1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-40369.json"
}
}
],
"modified": "2026-10-24T10:30:32.887143607Z",
"provider": "osv",
"references": [
"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-40369",
"https://lists.apache.org/thread/r2j00nrnpjgcmoxvlv3pgfoq9kzrcsfh"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-40369",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 433127,
"published_at": "2021-11-24T12:15:07.597+00:00"
}