Medium
spip — security advisory
svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.
- Products
- spip
- Affected versions
- 3.2.11-3, 3.2.12-1, 4.0.2-1, 4.0.4-1, 4.1.11+dfsg-1, 4.1.12+dfsg-1, 4.1.13+dfsg-1, 4.1.15+dfsg-1, 4.2.9+dfsg-2, 4.3.8+dfsg-1, 4.4.15+dfsg-1, 4.4.16+dfsg-1, 4.4.19+dfsg-1, 4.4.20+dfsg-1, 4.4.21+dfsg-1, 4.4.3+dfsg-1, 4.4.6+dfsg-1, 4.4.7+dfsg-1, 4.4.8+dfsg-1, 4.4.9+dfsg-1
- Fixed versions
- Not specified
- CVEs
- CVE-2022-23638
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 00:45 UTC · Revision 1
Source evidence
svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.
osv:UBUNTU-CVE-2022-23638
spip
Fixed versions: Not specified
spip
Fixed versions: Not specified
spip
Fixed versions: Not specified
spip
Fixed versions: Not specified
spip
Fixed versions: Not specified
Complete source record
{
"id": "7a0ac17f2188d3df34c5b06e7bdc70dd4f6d4f43e1c49dc2aef78612c39e613f",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-23638",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2022-23638",
"summary": "svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.",
"evidence": "osv:UBUNTU-CVE-2022-23638",
"products": [
{
"name": {
"value": "spip",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.2.11-3",
"evidence": "/affected/0/versions"
},
{
"value": "3.2.12-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.0.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.0.4-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "spip",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.1.11+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.1.12+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.1.13+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.1.15+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.2.9+dfsg-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "spip",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.3.8+dfsg-1",
"evidence": "/affected/2/versions"
},
{
"value": "4.4.3+dfsg-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "spip",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.9+dfsg-1",
"evidence": "/affected/3/versions"
},
{
"value": "4.4.15+dfsg-1",
"evidence": "/affected/3/versions"
},
{
"value": "4.4.16+dfsg-1",
"evidence": "/affected/3/versions"
},
{
"value": "4.4.19+dfsg-1",
"evidence": "/affected/3/versions"
},
{
"value": "4.4.20+dfsg-1",
"evidence": "/affected/3/versions"
},
{
"value": "4.4.21+dfsg-1",
"evidence": "/affected/3/versions"
}
]
},
{
"name": {
"value": "spip",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.3+dfsg-1",
"evidence": "/affected/4/versions"
},
{
"value": "4.4.6+dfsg-1",
"evidence": "/affected/4/versions"
},
{
"value": "4.4.7+dfsg-1",
"evidence": "/affected/4/versions"
},
{
"value": "4.4.8+dfsg-1",
"evidence": "/affected/4/versions"
},
{
"value": "4.4.9+dfsg-1",
"evidence": "/affected/4/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2022-23638",
"aliases": [
"UBUNTU-CVE-2022-23638"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/ubuntu/spip?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"3.2.11-3",
"3.2.12-1",
"4.0.2-1",
"4.0.4-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-23638.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "spip",
"binary_version": "4.0.4-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/ubuntu/spip?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"4.1.11+dfsg-1",
"4.1.12+dfsg-1",
"4.1.13+dfsg-1",
"4.1.15+dfsg-1",
"4.2.9+dfsg-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-23638.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "spip",
"binary_version": "4.2.9+dfsg-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/ubuntu/spip?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"4.3.8+dfsg-1",
"4.4.3+dfsg-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-23638.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "spip",
"binary_version": "4.4.3+dfsg-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/ubuntu/spip?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"4.4.9+dfsg-1",
"4.4.15+dfsg-1",
"4.4.16+dfsg-1",
"4.4.19+dfsg-1",
"4.4.20+dfsg-1",
"4.4.21+dfsg-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-23638.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "spip",
"binary_version": "4.4.21+dfsg-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/ubuntu/spip?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"4.4.3+dfsg-1",
"4.4.6+dfsg-1",
"4.4.7+dfsg-1",
"4.4.8+dfsg-1",
"4.4.9+dfsg-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-23638.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "spip",
"binary_version": "4.4.9+dfsg-1"
}
]
}
}
],
"modified": "2026-10-17T12:56:02.230157414Z",
"provider": "osv",
"upstream": [
"CVE-2022-23638"
],
"references": [
"https://ubuntu.com/security/CVE-2022-23638",
"https://github.com/darylldoyle/svg-sanitizer/commit/17e12ba9c2881caa6b167d0fbea555c11207fbb0",
"https://github.com/darylldoyle/svg-sanitizer/security/advisories/GHSA-fqx8-v33p-4qcc",
"https://www.cve.org/CVERecord?id=CVE-2022-23638",
"https://ubuntu.com/security/notices/USN-7318-1"
]
},
"related_cves": [
{
"value": "CVE-2022-23638",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 354636,
"published_at": "2022-02-14T21:15:00+00:00"
}