Security advisory
Elvish is a programming language and interactive shell, combined into one package. In versions prior to 0.14.0 Elvish's web UI backend (started by `elvish -web`) hosts an endpoint that allows executing the code sent from the web UI. The backend does not check the origin of requests correctly. As a result, if the user has the web UI backend open and visits a compromised or malicious website, the website can send arbitrary code to the endpoint in localhost. All Elvish releases from 0.14.0 onward no longer include the the web UI, although it is still possible for the user to build a version from source that includes the web UI. The issue can be patched for previous versions by removing the web UI (found in web, pkg/web or pkg/prog/web, depending on the exact version).
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-41088
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:56 UTC · Revision 1
Source evidence
Elvish is a programming language and interactive shell, combined into one package. In versions prior to 0.14.0 Elvish's web UI backend (started by `elvish -web`) hosts an endpoint that allows executing the code sent from the web UI. The backend does not check the origin of requests correctly. As a result, if the user has the web UI backend open and visits a compromised or malicious website, the website can send arbitrary code to the endpoint in localhost. All Elvish releases from 0.14.0 onward no longer include the the web UI, although it is still possible for the user to build a version from source that includes the web UI. The issue can be patched for previous versions by removing the web UI (found in web, pkg/web or pkg/prog/web, depending on the exact version).
osv:CVE-2021-41088
Complete source record
{
"id": "cdfab37bf93bf318d241a5a255481b530814401be3753a93f30dc22311975dc1",
"url": "https://osv.dev/vulnerability/CVE-2021-41088",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-41088",
"summary": "Elvish is a programming language and interactive shell, combined into one package. In versions prior to 0.14.0 Elvish's web UI backend (started by `elvish -web`) hosts an endpoint that allows executing the code sent from the web UI. The backend does not check the origin of requests correctly. As a result, if the user has the web UI backend open and visits a compromised or malicious website, the website can send arbitrary code to the endpoint in localhost. All Elvish releases from 0.14.0 onward no longer include the the web UI, although it is still possible for the user to build a version from source that includes the web UI. The issue can be patched for previous versions by removing the web UI (found in web, pkg/web or pkg/prog/web, depending on the exact version).",
"evidence": "osv:CVE-2021-41088",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-41088",
"aliases": [
"CVE-2021-41088",
"GHSA-fpv6-f8jw-rc3r",
"GO-2022-0937"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/elves/elvish",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "617d657896ac832fbb5eba7261cb95478a890092"
},
{
"fixed": "ccc2750037bbbfafe9c1b7a78eadd3bd16e81fe5"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:elv:elvish:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.14.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "ccc2750037bbbfafe9c1b7a78eadd3bd16e81fe5"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.14.0-rc1",
"v0.12.0",
"v0.12",
"v0.12-rc2",
"v0.12-rc1",
"v0.11.0",
"v0.11-rc2",
"v0.11",
"v0.11-rc1",
"v0.10.1",
"v0.10.0",
"v0.10",
"v0.9.0",
"v0.9",
"v0.8.0",
"v0.8",
"0.8",
"v0.7.0",
"v0.7",
"0.7",
"v0.6.0",
"v0.6",
"0.6",
"v0.5.0",
"v0.5",
"0.5",
"v0.4.0",
"v0.4",
"0.4",
"v0.3.0",
"v0.3",
"0.3",
"v0.2.0",
"v0.2",
"0.2",
"v0.1.0",
"v0.1",
"0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-41088.json"
}
}
],
"modified": "2026-10-20T10:54:57.649888462Z",
"provider": "osv",
"references": [
"https://github.com/elves/elvish/security/advisories/GHSA-fpv6-f8jw-rc3r",
"https://github.com/elves/elvish/commit/ccc2750037bbbfafe9c1b7a78eadd3bd16e81fe5"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-41088",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386554,
"published_at": "2021-09-23T20:15:07.72+00:00"
}