fscrypt — security advisory
The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
- Products
- fscrypt
- Affected versions
- Not specified
- Fixed versions
- 0.3.3-1
- CVEs
- CVE-2022-25328
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:48 UTC · Revision 1
Source evidence
The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
osv:DEBIAN-CVE-2022-25328
fscrypt
Fixed versions: 0.3.3-1
fscrypt
Fixed versions: 0.3.3-1
fscrypt
Fixed versions: 0.3.3-1
Complete source record
{
"id": "9c9c73219d6350037593a17d888b0d31e770d0dc6b1095138944e7cc1f948b70",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-25328",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-25328",
"summary": "The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above",
"evidence": "osv:DEBIAN-CVE-2022-25328",
"products": [
{
"name": {
"value": "fscrypt",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.3.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "fscrypt",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.3.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "fscrypt",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.3.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-25328",
"aliases": [
"DEBIAN-CVE-2022-25328"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.3.3-1"
}
]
}
],
"package": {
"name": "fscrypt",
"purl": "pkg:deb/debian/fscrypt?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25328.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.3.3-1"
}
]
}
],
"package": {
"name": "fscrypt",
"purl": "pkg:deb/debian/fscrypt?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25328.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.3.3-1"
}
]
}
],
"package": {
"name": "fscrypt",
"purl": "pkg:deb/debian/fscrypt?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25328.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:21.385117955Z",
"provider": "osv",
"upstream": [
"CVE-2022-25328"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-25328"
]
},
"related_cves": [
{
"value": "CVE-2022-25328",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323377,
"published_at": "2022-02-25T11:15:08.12+00:00"
}