Skip to content
Heist/ feed
Back to feed
MediumFix available

jetty9 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2023-41900

Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.

Products
jetty9
Affected versions
9.4.50-4
Fixed versions
9.4.50-4+deb12u1, 9.4.52-1
CVEs
CVE-2023-41900
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 16:25 UTC · Revision 1

Source evidence

DEBIAN-CVE-2023-41900

core-osv · Original source

Published 15 Sept 2023, 21:15 UTC

Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.

osv:DEBIAN-CVE-2023-41900

jetty9

Fixed versions: 9.4.50-4+deb12u1

jetty9

Fixed versions: 9.4.52-1

jetty9

Fixed versions: 9.4.52-1

Complete source record
{
  "id": "b5fa502e465ad5c966512c74d82482031a5b8a03555615a5fa16a2293c8f8e96",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-41900",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2023-41900",
    "summary": "Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.",
    "evidence": "osv:DEBIAN-CVE-2023-41900",
    "products": [
      {
        "name": {
          "value": "jetty9",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "9.4.50-4+deb12u1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "9.4.50-4",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "jetty9",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "9.4.52-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "jetty9",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "9.4.52-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2023-41900",
      "aliases": [
        "DEBIAN-CVE-2023-41900"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9.4.50-4+deb12u1"
                }
              ]
            }
          ],
          "package": {
            "name": "jetty9",
            "purl": "pkg:deb/debian/jetty9?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "9.4.50-4"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-41900.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9.4.52-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jetty9",
            "purl": "pkg:deb/debian/jetty9?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-41900.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9.4.52-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jetty9",
            "purl": "pkg:deb/debian/jetty9?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-41900.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T18:03:06.392588617Z",
      "provider": "osv",
      "upstream": [
        "CVE-2023-41900"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2023-41900"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2023-41900",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 457653,
  "published_at": "2023-09-15T21:15:11.6+00:00"
}