Security advisory
A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an unauthenticated attacker to crash the broker instance by sending specially crafted commands using AMQP protocol versions below 1.0 (AMQP 0-8, 0-9, 0-91 and 0-10). Users of Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 utilizing AMQP protocols 0-8, 0-9, 0-91, 0-10 must upgrade to Qpid Broker-J versions 7.0.7 or 7.1.1 or later.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-0200
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:38 UTC · Revision 1
Source evidence
A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an unauthenticated attacker to crash the broker instance by sending specially crafted commands using AMQP protocol versions below 1.0 (AMQP 0-8, 0-9, 0-91 and 0-10). Users of Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 utilizing AMQP protocols 0-8, 0-9, 0-91, 0-10 must upgrade to Qpid Broker-J versions 7.0.7 or 7.1.1 or later.
osv:CVE-2019-0200
Complete source record
{
"id": "af6285e7fdd3346699454e525c25cd40a3e8c64de9a105f9b7c8fe253a78e372",
"url": "https://osv.dev/vulnerability/CVE-2019-0200",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-0200",
"summary": "A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an unauthenticated attacker to crash the broker instance by sending specially crafted commands using AMQP protocol versions below 1.0 (AMQP 0-8, 0-9, 0-91 and 0-10). Users of Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 utilizing AMQP protocols 0-8, 0-9, 0-91, 0-10 must upgrade to Qpid Broker-J versions 7.0.7 or 7.1.1 or later.",
"evidence": "osv:CVE-2019-0200",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2019-0200",
"aliases": [
"CVE-2019-0200",
"GHSA-c9h6-xhg9-xxrv"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/qpid-broker-j",
"type": "GIT",
"events": [
{
"introduced": "8680024c437e0d97489fe50af6e3b0cd2825476b"
},
{
"last_affected": "cc29d4b6758f32ae6aef51550ee9018e5a7518ac"
},
{
"introduced": "5cb4ba20207da1390c79ef8b654a395e58dad5a0"
},
{
"last_affected": "5cb4ba20207da1390c79ef8b654a395e58dad5a0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:qpid_broker-j:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.0.0"
},
{
"last_affected": "7.0.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:qpid_broker-j:7.1.0:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.1.0"
},
{
"last_affected": "7.1.0"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"7.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-0200.json"
}
}
],
"modified": "2026-10-24T10:30:31.475213358Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread.html/ac79d48de37d42b64da50384dbe9c8a329c5f553dd12ef7c28a832de%40%3Cusers.qpid.apache.org%3E"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-0200",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 432822,
"published_at": "2019-03-06T18:29:00.247+00:00"
}