Skip to content
Heist/ feed
Back to feed
CriticalFix available

wordpress — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-44223

WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.

Products
wordpress
Affected versions
Not specified
Fixed versions
5.8.1+dfsg1-1
CVEs
CVE-2021-44223
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 01:42 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-44223

core-osv · Original source

Published 25 Nov 2021, 15:15 UTC

WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.

osv:DEBIAN-CVE-2021-44223

wordpress

Fixed versions: 5.8.1+dfsg1-1

wordpress

Fixed versions: 5.8.1+dfsg1-1

wordpress

Fixed versions: 5.8.1+dfsg1-1

Complete source record
{
  "id": "71b54631c5e60b6d00ad638efa1152ae919f6ee4fc77807dc588fa74ffae36d2",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-44223",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-44223",
    "summary": "WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.",
    "evidence": "osv:DEBIAN-CVE-2021-44223",
    "products": [
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.8.1+dfsg1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.8.1+dfsg1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.8.1+dfsg1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2021-44223",
      "aliases": [
        "DEBIAN-CVE-2021-44223"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.8.1+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-44223.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.8.1+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-44223.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.8.1+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-44223.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:04:50.075448880Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-44223"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-44223"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-44223",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 424047,
  "published_at": "2021-11-25T15:15:09.8+00:00"
}