Skip to content
Heist/ feed
Back to feed
Medium

Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin

Type: advisorySources: OSV

Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value. To remediate this issue, users should upgrade to version 4.3.0 or later.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-18061
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 05:48 UTC · Revision 1

Source evidence

Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin

core-osv · Original source

Published 11 Sept 2026, 16:33 UTC

Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value. To remediate this issue, users should upgrade to version 4.3.0 or later.

osv:CVE-2026-18061
Complete source record
{
  "id": "25889785e9c82a442e3faf1305d10f7b199631ddb6ee02b8d608e78a68493dbe",
  "url": "https://osv.dev/vulnerability/CVE-2026-18061",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin",
    "summary": "Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value. To remediate this issue, users should upgrade to version 4.3.0 or later.",
    "evidence": "osv:CVE-2026-18061",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-18061",
      "aliases": [
        "CVE-2026-18061",
        "GHSA-fpvp-qwgm-v6h9"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/aws/aws-advanced-jdbc-wrapper",
              "type": "GIT",
              "events": [
                {
                  "introduced": "095ec1b6f33b49aaa04d8c06c9e1a95227d24445"
                },
                {
                  "fixed": "bcddce78ffee28b0e408a3ff2d6a1942a5399cb3"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:amazon:advanced_jdbc_wrapper:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.3.0"
                      },
                      {
                        "fixed": "4.3.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "bcddce78ffee28b0e408a3ff2d6a1942a5399cb3"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "4.3.0"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-18061.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.177577127Z",
      "provider": "osv",
      "references": [
        "https://aws.amazon.com/security/security-bulletins/2026-109-aws/",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/18xxx/CVE-2026-18061.json",
        "https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-fpvp-qwgm-v6h9",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-18061",
        "https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/4.3.0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-611"
        ],
        "cna_assigner": "AMZN",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/18xxx/CVE-2026-18061.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-18061",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518400,
  "published_at": "2026-09-11T16:33:01.512+00:00"
}