Skip to content
Heist/ feed
Back to feed
HighFix available

node-min — security advisory

Type: advisorySources: OSVAdvisory ID: BIT-node-min-2021-22883

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

Products
node-min
Affected versions
Not specified
Fixed versions
10.24.0, 12.21.0, 14.16.0, 15.10.0
CVEs
CVE-2021-22883
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 19:54 UTC · Revision 1

Source evidence

BIT-node-min-2021-22883

core-osv · Original source

Published 16 Dec 2024, 14:06 UTC

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

osv:BIT-node-min-2021-22883

node-min

Fixed versions: 10.24.0, 12.21.0, 14.16.0, 15.10.0

Complete source record
{
  "id": "29e299e84f05bd40d7e83519812740be494210d33234aa5938839f87dfe1608f",
  "url": "https://osv.dev/vulnerability/BIT-node-min-2021-22883",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "BIT-node-min-2021-22883",
    "summary": "Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.",
    "evidence": "osv:BIT-node-min-2021-22883",
    "products": [
      {
        "name": {
          "value": "node-min",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "10.24.0",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "12.21.0",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "14.16.0",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "15.10.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "BIT-node-min-2021-22883",
      "aliases": [
        "BIT-node-2021-22883",
        "BIT-node-min-2021-22883",
        "CVE-2021-22883"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "10.0.0"
                },
                {
                  "fixed": "10.24.0"
                },
                {
                  "introduced": "12.0.0"
                },
                {
                  "fixed": "12.21.0"
                },
                {
                  "introduced": "14.0.0"
                },
                {
                  "fixed": "14.16.0"
                },
                {
                  "introduced": "15.0.0"
                },
                {
                  "fixed": "15.10.0"
                }
              ]
            }
          ],
          "package": {
            "name": "node-min",
            "purl": "pkg:bitnami/node-min",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V3",
              "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/node-min/BIT-node-min-2021-22883.json"
          }
        }
      ],
      "modified": "2026-10-16T09:45:30.408210252Z",
      "provider": "osv",
      "references": [
        "https://hackerone.com/reports/1043360",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/E4FRS5ZVK4ZQ7XIJQNGIKUXG2DJFHLO7/",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/F45Y7TXSU33MTKB6AGL2Q5V5ZOCNPKOG/",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HSYFUGKFUSZ27M5TEZ3FKILWTWFJTFAZ/",
        "https://nodejs.org/en/blog/vulnerability/february-2021-security-releases/",
        "https://security.netapp.com/advisory/ntap-20210416-0001/",
        "https://www.oracle.com//security-alerts/cpujul2021.html",
        "https://www.oracle.com/security-alerts/cpuApr2021.html",
        "https://www.oracle.com/security-alerts/cpuoct2021.html",
        "https://nvd.nist.gov/vuln/detail/CVE-2021-22883"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*",
          "cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*"
        ],
        "severity": "High"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2021-22883",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 338472,
  "published_at": "2024-12-16T14:06:06.63+00:00"
}