OpenClaw 2026.5.20 < 2026.6.9 Privilege Escalation via Plugin Install
OpenClaw versions 2026.5.20 before 2026.6.9 contain a privilege escalation vulnerability in plugin install commands that allows lower-trust callers to execute or persist actions beyond their intended authorization. Attackers can exploit misconfigured input paths or enabled features to escalate privileges and perform unauthorized actions when the feature is reachable.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-62194
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 02:11 UTC · Revision 1
Source evidence
OpenClaw 2026.5.20 < 2026.6.9 Privilege Escalation via Plugin Install
core-osv · Original sourcePublished 13 Jul 2026, 21:30 UTC
OpenClaw versions 2026.5.20 before 2026.6.9 contain a privilege escalation vulnerability in plugin install commands that allows lower-trust callers to execute or persist actions beyond their intended authorization. Attackers can exploit misconfigured input paths or enabled features to escalate privileges and perform unauthorized actions when the feature is reachable.
osv:CVE-2026-62194
Complete source record
{
"id": "4b4fe1cf8fce61d6336daba41659fe3463ac53b18574c9163a3ef4d011a33f19",
"url": "https://osv.dev/vulnerability/CVE-2026-62194",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenClaw 2026.5.20 < 2026.6.9 Privilege Escalation via Plugin Install",
"summary": "OpenClaw versions 2026.5.20 before 2026.6.9 contain a privilege escalation vulnerability in plugin install commands that allows lower-trust callers to execute or persist actions beyond their intended authorization. Attackers can exploit misconfigured input paths or enabled features to escalate privileges and perform unauthorized actions when the feature is reachable.",
"evidence": "osv:CVE-2026-62194",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-62194",
"aliases": [
"CVE-2026-62194",
"GHSA-7vrr-rp4x-4g76"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openclaw/openclaw",
"type": "GIT",
"events": [
{
"introduced": "e510042870cf248c0e0461b6f8d427326266141d"
},
{
"fixed": "c645ec4555c017931de0e35ad9847dffae2741ef"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2026.5.20"
},
{
"fixed": "2026.6.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "2026.5.20"
},
{
"fixed": "2026.6.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-62194.json"
}
}
],
"modified": "2026-10-28T02:30:32.428654238Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/62xxx/CVE-2026-62194.json",
"https://github.com/openclaw/openclaw/security/advisories/GHSA-7vrr-rp4x-4g76",
"https://nvd.nist.gov/vuln/detail/CVE-2026-62194",
"https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-plugin-install",
"https://github.com/openclaw/openclaw"
],
"provider_metadata": {
"cwe_ids": [
"CWE-732",
"CWE-862"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/62xxx/CVE-2026-62194.json"
}
},
"related_cves": [
{
"value": "CVE-2026-62194",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 499563,
"published_at": "2026-07-13T21:30:16.154+00:00"
}