Medium
OpenFGA Authorization Bypass
Type: advisorySources: OSV
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39341
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 00:58 UTC · Revision 1
Source evidence
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
osv:CVE-2022-39341
Complete source record
{
"id": "2b26db7a1fcfe199fdfaaf6b715995405c730170e81f89f8ed872de6e3b8891c",
"url": "https://osv.dev/vulnerability/CVE-2022-39341",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenFGA Authorization Bypass",
"summary": "OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.",
"evidence": "osv:CVE-2022-39341",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-39341",
"aliases": [
"CVE-2022-39341",
"GHSA-vj4m-83m8-xpw5",
"GO-2022-1080"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openfga/openfga",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "713c4808209dedee9bd2cfda1558c0ad0c71d5bb"
},
{
"fixed": "b466769cc100b2065047786578718d313f52695b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.2.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "b466769cc100b2065047786578718d313f52695b"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "713c4808209dedee9bd2cfda1558c0ad0c71d5bb"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v0.2.4"
}
]
}
}
],
"versions": [
"v0.2.3",
"v0.2.2",
"v0.2.1",
"v0.2.0",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39341.json"
}
}
],
"modified": "2026-10-28T02:30:32.621225299Z",
"provider": "osv",
"references": [
"https://github.com/openfga/openfga/releases/tag/v0.2.4",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39341.json",
"https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39341",
"https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695b"
],
"provider_metadata": {
"cwe_ids": [
"CWE-285"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39341.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39341",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 499387,
"published_at": "2022-10-25T00:00:00+00:00"
}