Apache APISIX: cross-request permission pollution via static permission list mutation
Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.
- Products
- apisix
- Affected versions
- Not specified
- Fixed versions
- 3.7.0
- CVEs
- CVE-2026-82806
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:32 UTC · Revision 1
Source evidence
Apache APISIX: cross-request permission pollution via static permission list mutation
core-osv · Original sourcePublished 9 Oct 2026, 10:43 UTC
Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.
osv:BIT-apisix-2026-82806
apisix
Fixed versions: 3.7.0
Complete source record
{
"id": "8a082a5d16e3f8aa8b8bf6722a52e4a2a5616d86cd0e0bcc2b60f7cb0f2d60e3",
"url": "https://osv.dev/vulnerability/BIT-apisix-2026-82806",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: cross-request permission pollution via static permission list mutation",
"summary": "Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.",
"evidence": "osv:BIT-apisix-2026-82806",
"products": [
{
"name": {
"value": "apisix",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.7.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-apisix-2026-82806",
"aliases": [
"BIT-apisix-2026-82806",
"CVE-2026-82806"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "3.7.0"
}
]
}
],
"package": {
"name": "apisix",
"purl": "pkg:bitnami/apisix",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/apisix/BIT-apisix-2026-82806.json"
}
}
],
"modified": "2026-10-09T12:00:05.382953962Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread.html/wvkv2b4oy2fh9v79d30gtsy0bhqmzcdd",
"https://nvd.nist.gov/vuln/detail/CVE-2026-82806"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2026-82806",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120650,
"published_at": "2026-10-09T10:43:46.734+00:00"
}