Skip to content
Heist/ feed
Back to feed
Medium

OpenProject: Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements

Type: advisorySources: OSV

OpenProject is open-source, web-based project management software. Prior to 17.3.2 and 17.4.0, Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements. A password validation flaw in the change password behavior allows attackers to change a user's password only with an active session takeover. This vulnerability is fixed in 17.3.2 and 17.4.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-44733
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 18:46 UTC · Revision 1

Source evidence

OpenProject: Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements

core-osv · Original source

Published 26 Jun 2026, 19:47 UTC

OpenProject is open-source, web-based project management software. Prior to 17.3.2 and 17.4.0, Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements. A password validation flaw in the change password behavior allows attackers to change a user's password only with an active session takeover. This vulnerability is fixed in 17.3.2 and 17.4.0.

osv:CVE-2026-44733
Complete source record
{
  "id": "38081ca67382e33836d26755eae7e981cea45991b242a0efba379690deaf2dd0",
  "url": "https://osv.dev/vulnerability/CVE-2026-44733",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "OpenProject: Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements",
    "summary": "OpenProject is open-source, web-based project management software. Prior to 17.3.2 and 17.4.0, Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements. A password validation flaw in the change password behavior allows attackers to change a user's password only with an active session takeover. This vulnerability is fixed in 17.3.2 and 17.4.0.",
    "evidence": "osv:CVE-2026-44733",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-44733",
      "aliases": [
        "CVE-2026-44733",
        "GHSA-px7f-cj9f-7m4m"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/opf/openproject",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "cd0d46e68f91e27deeb1fd12511a646043612498"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "17.3.2"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "17.3.2"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v17.3.1",
            "11.2.1",
            "v10.5",
            "v9.0.0-pre",
            "v5.0.4",
            "sprint/2015_04",
            "sprint/2015_03",
            "sprint/2015_02",
            "sprint/2015_01",
            "sprint/2014_18",
            "sprint/2014_16",
            "sprint/2014_13",
            "sprint/2014_12",
            "sprint/2014_11",
            "sprint/2014_10",
            "sprint/2014_09",
            "sprint/2014_08",
            "2.4.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-44733.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:22.233471489Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44733.json",
        "https://github.com/opf/openproject/security/advisories/GHSA-px7f-cj9f-7m4m",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-44733"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-620"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44733.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-44733",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 488731,
  "published_at": "2026-06-26T19:47:13.724+00:00"
}