Medium
Security advisory
connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-3717
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 09:51 UTC · Revision 1
Source evidence
connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.
osv:CVE-2018-3717
Complete source record
{
"id": "77b92bdeb52ecc4db0f9392e976fbe9e417ebf08ae3953bfbca19323af2faffc",
"url": "https://osv.dev/vulnerability/CVE-2018-3717",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-3717",
"summary": "connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.",
"evidence": "osv:CVE-2018-3717",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-3717",
"aliases": [
"CVE-2018-3717",
"GHSA-rch9-xh7r-mqgw"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/senchalabs/connect",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "ec7941bb3ab97b1870f6d2b88a76c900ef269edf"
},
{
"fixed": "6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:sencha:connect:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.14.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"2.13.0",
"2.12.0",
"2.11.2",
"2.11.1",
"2.11.0",
"2.10.1",
"2.10.0",
"2.9.2",
"2.9.1",
"2.9.0",
"2.8.8",
"2.8.7",
"0.8.6",
"2.8.5",
"2.8.4",
"2.8.3",
"2.8.2",
"2.8.1",
"2.8.0",
"2.7.11",
"2.7.10",
"2.7.9",
"2.7.8",
"2.7.7",
"2.7.6",
"2.7.5",
"2.7.4",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7.0",
"2.6.2",
"2.4.5",
"2.4.4",
"2.4.3",
"2.4.2",
"2.4.1",
"2.4.0",
"2.3.9",
"2.3.8",
"2.3.7",
"rm",
"2.3.6",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.3.0",
"2.2.2",
"2.2.1",
"2.2.0",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0.0",
"2.0.0alpha1",
"1.6.0",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.6",
"1.4.5",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.0",
"1.2.3",
"1.2.2",
"1.2.1",
"1.2.0",
"1.1.5",
"1.1.4",
"1.1.3",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.6",
"1.0.5",
"1.0.4",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0",
"0.5.9",
"0.5.8",
"0.5.7",
"0.5.6",
"0.5.5",
"0.5.4",
"0.5.3",
"0.5.2",
"0.5.1",
"0.5.0",
"0.4.0",
"0.3.0",
"0.2.7",
"0.2.6",
"0.2.5",
"0.2.4",
"0.2.3",
"0.2.2",
"0.2.1",
"0.2.0",
"0.1.0",
"0.0.6",
"0.0.5",
"0.0.4",
"0.0.3",
"0.0.2",
"0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-3717.json"
}
}
],
"modified": "2026-10-20T10:48:10.104890071Z",
"provider": "osv",
"references": [
"https://github.com/senchalabs/connect/commit/6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b",
"https://hackerone.com/reports/309394",
"https://hackerone.com/reports/309641"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-3717",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 380108,
"published_at": "2018-06-07T02:29:08.13+00:00"
}