Skip to content
Heist/ feed
Back to feed
CriticalFix available

Drupal core - Critical - Cache poisoning - SA-CORE-2023-006

Type: patchSources: Drupal security

Drupal core's JSON:API module can expose error backtraces that may cause sensitive information to be cached and available to anonymous users. The issue affects sites with JSON:API enabled; update to the fixed version for your Drupal branch or uninstall JSON:API as a mitigation.

Products
Drupal core
Affected versions
>=8.7.0 <9.5.11 || >=10.0 <10.0.11 || >= 10.1 <10.1.4
Fixed versions
Drupal 10.0.11, Drupal 10.1.4, Drupal 9.5.11
CVEs
CVE-2023-5256
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 14:12 UTC · Revision 1

Source evidence

Drupal core - Critical - Cache poisoning - SA-CORE-2023-006

official-drupal-security · Original source

Published 20 Sept 2023, 16:23 UTC

Drupal core's JSON:API module can expose error backtraces that may cause sensitive information to be cached and available to anonymous users. The issue affects sites with JSON:API enabled; update to the fixed version for your Drupal branch or uninstall JSON:API as a mitigation.

In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation.

Drupal core

Fixed versions: Drupal 10.1.4, Drupal 10.0.11, Drupal 9.5.11

Prerequisites: JSON:API module enabled

Complete source record
{
  "id": "7a2762fde337467c073e4205f79b724594b3837a163fcf62a8b6de6f5a52adc8",
  "url": "https://www.drupal.org/sa-core-2023-006",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Critical - Cache poisoning - SA-CORE-2023-006",
    "summary": "Drupal core's JSON:API module can expose error backtraces that may cause sensitive information to be cached and available to anonymous users. The issue affects sites with JSON:API enabled; update to the fixed version for your Drupal branch or uninstall JSON:API as a mitigation.",
    "evidence": "In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [
          {
            "value": "JSON:API module enabled",
            "evidence": "This vulnerability only affects sites with the JSON:API module enabled"
          }
        ],
        "fixed_versions": [
          {
            "value": "Drupal 10.1.4",
            "evidence": "If you are using Drupal 10.1, update to Drupal 10.1.4."
          },
          {
            "value": "Drupal 10.0.11",
            "evidence": "If you are using Drupal 10.0, update to Drupal 10.0.11."
          },
          {
            "value": "Drupal 9.5.11",
            "evidence": "If you are using Drupal 9.5, update to Drupal 9.5.11."
          }
        ],
        "affected_versions": [
          {
            "value": ">=8.7.0 <9.5.11 || >=10.0 <10.0.11 || >= 10.1 <10.1.4",
            "evidence": "Affected versions: >=8.7.0 <9.5.11 || >=10.0 <10.0.11 || >= 10.1 <10.1.4"
          }
        ]
      }
    ],
    "severity": "critical",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2023-5256",
        "evidence": "CVE IDs: CVE-2023-5256"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "Security risk: Critical"
  },
  "source_id": "official-drupal-security",
  "document_id": 23484,
  "published_at": "2023-09-20T16:23:05+00:00"
}