Security advisory
In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-15107
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 12:37 UTC · Revision 1
Source evidence
In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.
osv:CVE-2020-15107
Complete source record
{
"id": "59d287f39597ed9fbbf0de101cdbb5b94410d9deccca0f1f3ad2d798c2070af1",
"url": "https://osv.dev/vulnerability/CVE-2020-15107",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-15107",
"summary": "In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.",
"evidence": "osv:CVE-2020-15107",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2020-15107",
"aliases": [
"CVE-2020-15107",
"GHSA-7wjx-wcwg-w999"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openenclave/openenclave",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6046f509e92acab3e358d325a5f600bb1556cfc8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:openenclave:openenclave:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.10.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.10.0-rc1",
"v0.8.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15107.json",
"vanir_signatures": [
{
"id": "CVE-2020-15107-76d616d4",
"digest": {
"threshold": 0.9,
"line_hashes": [
"82492698400470469814835135228437921432",
"115069713648466554486591495679381535160",
"117238677730152659075567035374989232122",
"187611219419099697542933833105776477887"
]
},
"source": "https://github.com/openenclave/openenclave/commit/6046f509e92acab3e358d325a5f600bb1556cfc8",
"target": {
"file": "samples/pluggable_allocator/host/host.cpp"
},
"deprecated": false,
"signature_type": "Line",
"signature_version": "v1"
}
],
"vanir_signatures_modified": "2026-10-20T14:00:31Z"
}
}
],
"modified": "2026-10-20T14:00:31.758972139Z",
"provider": "osv",
"references": [
"https://github.com/openenclave/openenclave/security/advisories/GHSA-7wjx-wcwg-w999"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-15107",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 388513,
"published_at": "2020-07-15T22:15:13.967+00:00"
}