ruby-nokogiri — security advisory
Nokogiri is an open source XML and HTML library for the Ruby programming language. Nokogiri `1.13.8` and `1.13.9` fail to check the return value from `xmlTextReaderExpand` in the method `Nokogiri::XML::Reader#attribute_hash`. This can lead to a null pointer exception when invalid markup is being parsed. For applications using `XML::Reader` to parse untrusted inputs, this may potentially be a vector for a denial of service attack. Users are advised to upgrade to Nokogiri `>= 1.13.10`. Users may be able to search their code for calls to either `XML::Reader#attributes` or `XML::Reader#attribute_hash` to determine if they are affected.
- Products
- ruby-nokogiri
- Affected versions
- Not specified
- Fixed versions
- 1.13.10+dfsg-1
- CVEs
- CVE-2022-23476
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:35 UTC · Revision 1
Source evidence
Nokogiri is an open source XML and HTML library for the Ruby programming language. Nokogiri `1.13.8` and `1.13.9` fail to check the return value from `xmlTextReaderExpand` in the method `Nokogiri::XML::Reader#attribute_hash`. This can lead to a null pointer exception when invalid markup is being parsed. For applications using `XML::Reader` to parse untrusted inputs, this may potentially be a vector for a denial of service attack. Users are advised to upgrade to Nokogiri `>= 1.13.10`. Users may be able to search their code for calls to either `XML::Reader#attributes` or `XML::Reader#attribute_hash` to determine if they are affected.
osv:DEBIAN-CVE-2022-23476
ruby-nokogiri
Fixed versions: 1.13.10+dfsg-1
ruby-nokogiri
Fixed versions: 1.13.10+dfsg-1
ruby-nokogiri
Fixed versions: 1.13.10+dfsg-1
Complete source record
{
"id": "967af47e08e349a4c62d542af77d02d87d919faf4597b35d25dfc475036f9202",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23476",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-23476",
"summary": "Nokogiri is an open source XML and HTML library for the Ruby programming language. Nokogiri `1.13.8` and `1.13.9` fail to check the return value from `xmlTextReaderExpand` in the method `Nokogiri::XML::Reader#attribute_hash`. This can lead to a null pointer exception when invalid markup is being parsed. For applications using `XML::Reader` to parse untrusted inputs, this may potentially be a vector for a denial of service attack. Users are advised to upgrade to Nokogiri `>= 1.13.10`. Users may be able to search their code for calls to either `XML::Reader#attributes` or `XML::Reader#attribute_hash` to determine if they are affected.",
"evidence": "osv:DEBIAN-CVE-2022-23476",
"products": [
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.10+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.10+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.10+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-23476",
"aliases": [
"DEBIAN-CVE-2022-23476"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.10+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23476.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.10+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23476.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.10+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23476.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:00:48.149368792Z",
"provider": "osv",
"upstream": [
"CVE-2022-23476"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-23476"
]
},
"related_cves": [
{
"value": "CVE-2022-23476",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322653,
"published_at": "2022-12-08T04:15:09.043+00:00"
}