Skip to content
Heist/ feed
Back to feed
Low

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-1544

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-1544
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:57 UTC · Revision 1

Source evidence

CVE-2016-1544

core-osv · Original source

Published 6 Feb 2020, 15:15 UTC

nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).

osv:CVE-2016-1544
Complete source record
{
  "id": "3db0187fcb98d81796e590d170708bbd9a1765dc7399493663b6ddb01e35dfa7",
  "url": "https://osv.dev/vulnerability/CVE-2016-1544",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-1544",
    "summary": "nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).",
    "evidence": "osv:CVE-2016-1544",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2016-1544",
      "aliases": [
        "CVE-2016-1544"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/nghttp2/nghttp2",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5563a0bea6045b863659de58e98b2876cb34a256"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.7.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "5563a0bea6045b863659de58e98b2876cb34a256"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.7.1"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.7.0",
            "v1.6.0",
            "v1.5.0",
            "v1.4.0",
            "v1.3.4",
            "v1.3.3",
            "v1.3.2",
            "v1.3.1",
            "v1.3.0",
            "v1.2.1",
            "v1.2.0",
            "v1.1.2",
            "v1.1.1",
            "v1.1.0",
            "v1.0.5",
            "v1.0.4",
            "v1.0.3",
            "v1.0.2",
            "v1.0.1",
            "v1.0.0",
            "v0.7.15",
            "v0.7.14",
            "v0.7.13",
            "v0.7.12",
            "v0.7.11",
            "v0.7.10",
            "v0.7.9",
            "v0.7.8",
            "v0.7.7",
            "v0.7.6",
            "v0.7.5",
            "v0.7.4",
            "v0.7.3",
            "v0.7.2",
            "v0.7.1",
            "v0.7.0",
            "v0.6.7",
            "v0.6.6",
            "v0.6.5",
            "v0.6.4",
            "v0.6.3",
            "v0.6.2",
            "v0.6.1",
            "v0.6.0",
            "v0.5.1",
            "v0.5.0",
            "v0.4.1",
            "v0.4.0",
            "v0.3.1",
            "v0.3.0",
            "v0.2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-1544.json"
          }
        }
      ],
      "modified": "2026-10-20T10:49:30.856952029Z",
      "provider": "osv",
      "references": [
        "https://github.com/nghttp2/nghttp2/compare/v1.7.0...v1.7.1",
        "https://github.com/nghttp2/nghttp2/releases/tag/v1.7.1",
        "https://security.gentoo.org/glsa/201612-13",
        "https://bugzilla.redhat.com/show_bug.cgi?id=1308461"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*",
              "cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*"
            ],
            "vendor_product": "fedoraproject:fedora",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "22"
                  },
                  {
                    "last_affected": "22"
                  },
                  {
                    "introduced": "23"
                  },
                  {
                    "last_affected": "23"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2016-1544",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 380506,
  "published_at": "2020-02-06T15:15:11.17+00:00"
}