Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-25070

A vulnerability has been found in polterguy Phosphorus Five up to 8.2 and classified as critical. This vulnerability affects the function csv.Read of the file plugins/extras/p5.mysql/NonQuery.cs of the component CSV Import. The manipulation leads to sql injection. Upgrading to version 8.3 is able to address this issue. The patch is identified as c179a3d0703db55cfe0cb939b89593f2e7a87246. It is recommended to upgrade the affected component. VDB-217606 is the identifier assigned to this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-25070
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:19 UTC · Revision 1

Source evidence

CVE-2018-25070

core-osv · Original source

Published 7 Jan 2023, 11:15 UTC

A vulnerability has been found in polterguy Phosphorus Five up to 8.2 and classified as critical. This vulnerability affects the function csv.Read of the file plugins/extras/p5.mysql/NonQuery.cs of the component CSV Import. The manipulation leads to sql injection. Upgrading to version 8.3 is able to address this issue. The patch is identified as c179a3d0703db55cfe0cb939b89593f2e7a87246. It is recommended to upgrade the affected component. VDB-217606 is the identifier assigned to this vulnerability.

osv:CVE-2018-25070
Complete source record
{
  "id": "83274f7f746314ad04766dd29a43ff92bfc76ecb731f6e37ceaf0ec8954d9a51",
  "url": "https://osv.dev/vulnerability/CVE-2018-25070",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-25070",
    "summary": "A vulnerability has been found in polterguy Phosphorus Five up to 8.2 and classified as critical. This vulnerability affects the function csv.Read of the file plugins/extras/p5.mysql/NonQuery.cs of the component CSV Import. The manipulation leads to sql injection. Upgrading to version 8.3 is able to address this issue. The patch is identified as c179a3d0703db55cfe0cb939b89593f2e7a87246. It is recommended to upgrade the affected component. VDB-217606 is the identifier assigned to this vulnerability.",
    "evidence": "osv:CVE-2018-25070",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2018-25070",
      "aliases": [
        "CVE-2018-25070"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/polterguy/phosphorusfive",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "17502d638c0a1d5b827a579fb2d6270f6a731d32"
                },
                {
                  "fixed": "c179a3d0703db55cfe0cb939b89593f2e7a87246"
                },
                {
                  "fixed": "f40007f45f905658e4c3877bf66cd0584550789d"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:aista:phosphorus_five:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "8.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "c179a3d0703db55cfe0cb939b89593f2e7a87246"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "f40007f45f905658e4c3877bf66cd0584550789d"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v8.3"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v8.2",
            "v8.1.1",
            "v8.1",
            "v8.0",
            "v7.2",
            "v7.0",
            "v6.2",
            "v6.1",
            "v6.0",
            "v5.9",
            "v5.8",
            "v5.7",
            "v5.5",
            "v5.1",
            "v5.0",
            "v4.96",
            "v4.95",
            "v4.9",
            "v4.8BETA",
            "v4.7",
            "v4.5",
            "v4.4",
            "v4.3",
            "v4.2",
            "v4.1",
            "v4.0-2",
            "v4.0-x",
            "v4.0-RC2",
            "v4.0-RC1",
            "v4.0-BETA2",
            "v4.0-BETA1",
            "v4.0",
            "v3.3",
            "v3.2",
            "v3.1",
            "v3.0",
            "v2.2",
            "v2.1",
            "v2.0",
            "v1.1",
            "v1.1-BETA1",
            "v1.0",
            "v1.0-RC3",
            "v1.0-RC2",
            "v1.0-RC1",
            "v1.0-BETA22",
            "v1.0-BETA21",
            "v1.0-BETA20",
            "v1.0-BETA19",
            "v1.0-BETA18",
            "v1.0-BETA17",
            "v1.0-BETA16",
            "v1.0-BETA15",
            "v1.0-BETA14",
            "v1.0-BETA13",
            "v1.0-BETA12",
            "v1.0-BETA11",
            "v1.0-BETA10",
            "v1.0-BETA9",
            "v1.0-BETA8",
            "v1.0-BETA7",
            "v1.0-BETA6",
            "v1.0-BETA5",
            "v1.0-BETA4",
            "v1.0-BETA3",
            "v1.0-BETA2",
            "v1.0-BETA"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-25070.json"
          }
        }
      ],
      "modified": "2026-10-20T10:50:08.091291606Z",
      "provider": "osv",
      "references": [
        "https://github.com/polterguy/phosphorusfive/releases/tag/v8.3",
        "https://vuldb.com/?id.217606",
        "https://vuldb.com/?ctiid.217606",
        "https://github.com/polterguy/phosphorusfive/commit/c179a3d0703db55cfe0cb939b89593f2e7a87246"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-25070",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 381326,
  "published_at": "2023-01-07T11:15:08.91+00:00"
}